aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/certs.scm
diff options
context:
space:
mode:
authorBrian Kubisiak <brian@kubisiak.com>2022-04-02 17:49:15 -0700
committerLudovic Courtès <ludo@gnu.org>2022-05-02 22:22:31 +0200
commit555ddf0dd7e9715d9683b62ec8560735416d2c0d (patch)
tree48170725fccd447d3255ba42ec0fa7d72d9cde0e /gnu/packages/certs.scm
parent65e3de5cce7b921f07515b633ab9ac7199a2598f (diff)
downloadguix-555ddf0dd7e9715d9683b62ec8560735416d2c0d.tar
guix-555ddf0dd7e9715d9683b62ec8560735416d2c0d.tar.gz
gnu: nss-certs: Use G-Expression.
* gnu/packages/certs.scm (nss-certs)[arguments]: Use a gexp. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/certs.scm')
-rw-r--r--gnu/packages/certs.scm47
1 files changed, 22 insertions, 25 deletions
diff --git a/gnu/packages/certs.scm b/gnu/packages/certs.scm
index d410b05860..53fb027563 100644
--- a/gnu/packages/certs.scm
+++ b/gnu/packages/certs.scm
@@ -28,6 +28,7 @@
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
@@ -159,31 +160,27 @@ that was originally contributed to Debian.")
(inputs '())
(propagated-inputs '())
(arguments
- `(#:modules ((guix build gnu-build-system)
- (guix build utils)
- (rnrs io ports)
- (srfi srfi-26))
- #:phases
- (modify-phases
- (map (cut assq <> %standard-phases)
- '(set-paths install-locale unpack))
- (add-after 'unpack 'install
- (lambda _
- ;; TODO: On the next rebuild cycle, remove references to
- ;; '%output' and '%outputs'.
- (let ((certsdir (string-append ,(if (%current-target-system)
- '(assoc-ref %outputs "out")
- '%output)
- "/etc/ssl/certs/")))
- (with-directory-excursion "nss/lib/ckfw/builtins/"
- (unless (file-exists? "blacklist.txt")
- (call-with-output-file "blacklist.txt" (const #t)))
- ;; Extract selected single certificates from blob.
- (invoke "certdata2pem")
- ;; Copy .pem files into the output.
- (for-each (cut install-file <> certsdir)
- (find-files "." ".*\\.pem$")))
- (invoke "openssl" "rehash" certsdir)))))))
+ (list #:modules '((guix build gnu-build-system)
+ (guix build utils)
+ (rnrs io ports)
+ (srfi srfi-26))
+ #:phases
+ #~(modify-phases
+ (map (cut assq <> %standard-phases)
+ '(set-paths install-locale unpack))
+ (add-after 'unpack 'install
+ (lambda _
+ (let ((certsdir (string-append #$output
+ "/etc/ssl/certs/")))
+ (with-directory-excursion "nss/lib/ckfw/builtins/"
+ (unless (file-exists? "blacklist.txt")
+ (call-with-output-file "blacklist.txt" (const #t)))
+ ;; Extract selected single certificates from blob.
+ (invoke "certdata2pem")
+ ;; Copy .pem files into the output.
+ (for-each (cut install-file <> certsdir)
+ (find-files "." ".*\\.pem$")))
+ (invoke "openssl" "rehash" certsdir)))))))
(synopsis "CA certificates from Mozilla")
(description
"This package provides certificates for Certification Authorities (CA)