aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2023-11-01 22:57:14 +0000
committerLudovic Courtès <ludo@gnu.org>2023-12-02 12:25:46 +0100
commitaa4959e602998e753f12a99ab38c4a8ab19e2171 (patch)
tree203ad6a4624733e033cd2f980e5be3ceced83282 /gnu/packages/c.scm
parentb0715d7cd2a74bc231751f8afc9dffb2047501ac (diff)
downloadguix-aa4959e602998e753f12a99ab38c4a8ab19e2171.tar
guix-aa4959e602998e753f12a99ab38c4a8ab19e2171.tar.gz
gnu: Add pcg-c.
* gnu/packages/c.scm (pcg-c): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index da0d11e8f7..ac83336ba5 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;; Copyright © 2023 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
+;;; Copyright © 2023 David Elsing <david.elsing@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1588,3 +1589,57 @@ serial program, though the execution model is actually that a number of
program instances execute in parallel on the hardware.")
(home-page "https://github.com/ispc/ispc")
(license license:bsd-3)))
+
+(define-public pcg-c
+ (let ((commit "83252d9c23df9c82ecb42210afed61a7b42402d7")
+ (revision "1"))
+ (package
+ (name "pcg-c")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/imneme/pcg-c")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0768h0vw75a3smk39qsz1504v04a43s5w1ili1ijbixxv8gm42nf"))
+ (modules '((guix build utils)))
+ ;; Autogenerated files with some tests from test-high. If
+ ;; 128-bit integers are not supported, the build fails, but
+ ;; this is checked when building the tests.
+ (snippet #~(delete-file-recursively "sample"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:test-target "test"
+ #:make-flags
+ #~(list
+ "CC=gcc"
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'disable-sample
+ (lambda _
+ (substitute* "Makefile"
+ ((".*cd sample.*") ""))))
+ (add-after 'unpack 'set-shared-library
+ (lambda _
+ (substitute* '("Makefile" "src/Makefile")
+ (("\\.a") "\\.so")
+ ((".*ar .*") "\t$(CC) $(CFLAGS) -o $@ $(LDFLAGS) -shared $^")
+ ((".*ranlib.*") "")
+ ((".*CFLAGS \\+=.*O3.*" orig)
+ (string-append orig "CFLAGS += -fPIC\n")))))
+ (add-before 'install 'make-dirs
+ (lambda _
+ (mkdir-p (string-append #$output "/lib"))
+ (mkdir-p (string-append #$output "/include")))))))
+ (home-page "https://www.pcg-random.org")
+ (synopsis "C implementation of the PCG random generators")
+ (description "The Permuted Congruential Generator (PCG) extends the
+Linear Congruential Generator (LCG) with a permutation function to increase
+output randomness while retaining speed, simplicity, and conciseness.")
+ (license (list license:expat license:asl2.0))))) ; dual licensed