aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-01 17:05:20 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-01 17:29:00 -0400
commit44422c1fba5b3169797749f84737331680972f60 (patch)
tree41aaa678c8b3af60a19882492581a80f2cc99398 /gnu/packages/c.scm
parenteeffc4ed04795e170dead11159da266e9394702c (diff)
downloadguix-44422c1fba5b3169797749f84737331680972f60.tar
guix-44422c1fba5b3169797749f84737331680972f60.tar.gz
gnu: utf8-h: Install header under include/utf8 prefix.
This is to standardize with the usage of the library in the package's only current user, OpenBoardView. It also matches the installation layout of the Arch package, which is made by its author. * gnu/packages/c.scm (utf8-h) [arguments]: Use gexps. Adjust installation prefix to 'include/utf8' in install phase. * gnu/packages/electronics.scm (openboardview) [arguments]: Delete fix-utf8-include-directive phase.
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 96b4e904f7..b12aaf184a 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -1365,20 +1365,21 @@ will take care of dispatching tasks to available cores.")
"0x9f7ivww8c7cigf4ck0hfx2bm79qgx6q4ccwzqbzkrmcrl9shfb"))))
(build-system cmake-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (delete 'build)
- (delete 'configure)
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (with-directory-excursion "test"
- (invoke "cmake" ".")
- (invoke "make")))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (install-file "utf8.h" (string-append out "/include"))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'build)
+ (delete 'configure)
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "test"
+ (invoke "cmake" ".")
+ (invoke "make")))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "utf8.h"
+ (string-append #$output "/include/utf8")))))))
(home-page "https://github.com/sheredom/utf8.h")
(synopsis "Single header UTF-8 string functions for C and C++")
(description "A simple one header solution to supporting UTF-8 strings in