aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-05-21 16:17:46 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-05-21 16:19:03 +0200
commit07592c77a66d595e912cbe1c54ced5ac0d71d028 (patch)
tree7c996858b58a899874ebcfc342e0784f3bb24416 /gnu/packages/c.scm
parent453031a0ac2a5848cb59c8b9610bb3942f77b9fe (diff)
downloadguix-07592c77a66d595e912cbe1c54ced5ac0d71d028.tar
guix-07592c77a66d595e912cbe1c54ced5ac0d71d028.tar.gz
gnu: Add libfixposix.
* gnu/packages/c.scm (libfixposix): New variable.
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm31
1 files changed, 30 insertions, 1 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 2629ebb6dd..41946f4169 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2016, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2018, 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
@@ -29,6 +29,7 @@
#:use-module (guix build-system trivial)
#:use-module (gnu packages bootstrap)
#:use-module (gnu packages bison)
+ #:use-module (gnu packages check)
#:use-module (gnu packages flex)
#:use-module (gnu packages perl)
#:use-module (gnu packages texinfo)
@@ -287,3 +288,31 @@ Its three main components are:
@end enumerate\n")
;; Like the BSD-3 license but with an extra anti patent clause.
(license (license:non-copyleft "file://COPYRIGHT"))))
+
+(define-public libfixposix
+ (package
+ (name "libfixposix")
+ (version "0.4.3")
+ (home-page "https://github.com/sionescu/libfixposix")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1x4q6yspi5g2s98vq4qszw4z3zjgk9l5zs8471w4d4cs6l97w08j"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("check" ,check)))
+ (synopsis "Thin wrapper over POSIX syscalls")
+ (description
+ "The purpose of libfixposix is to offer replacements for parts of POSIX
+whose behaviour is inconsistent across *NIX flavours.")
+ (license license:boost1.0)))