aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/busybox.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:00 +0200
commit38787e36c1fc8108e93bcc702c5de44000a161ca (patch)
treeeef8c2576a5c09dc4f239f819399d177b76092cd /gnu/packages/busybox.scm
parentb55d0f553b4823afd49f3ebd979b90b94d54da22 (diff)
downloadguix-38787e36c1fc8108e93bcc702c5de44000a161ca.tar
guix-38787e36c1fc8108e93bcc702c5de44000a161ca.tar.gz
gnu: toybox: Use #:make-flags.
* gnu/packages/busybox.scm (toybox)[arguments]: Add #:make-flags to replace ad hoc use of environment variables and custom phases. Remove the 'set-environment-variables and custom 'install phase.
Diffstat (limited to 'gnu/packages/busybox.scm')
-rw-r--r--gnu/packages/busybox.scm18
1 files changed, 7 insertions, 11 deletions
diff --git a/gnu/packages/busybox.scm b/gnu/packages/busybox.scm
index 8624f1f816..4468d71088 100644
--- a/gnu/packages/busybox.scm
+++ b/gnu/packages/busybox.scm
@@ -131,14 +131,15 @@ any small or embedded system.")
"150lvp7hf9ndafvmr42kb8xi86hxjd2zj4binwwhgjw2dwrvy25m"))))
(build-system gnu-build-system)
(arguments
- (list #:phases
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "HOSTCC=gcc")
+ (string-append "PREFIX=" #$output))
+ #:phases
#~(modify-phases %standard-phases
- (add-before 'configure 'set-environment-variables
- (lambda _
- (setenv "CC" #$(cc-for-target))
- (setenv "HOSTCC" (which "gcc"))))
(replace 'configure
- (lambda _ (invoke "make" "defconfig")))
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "defconfig" make-flags)))
(add-before 'check 'fix-or-skip-broken-tests
(lambda _
;; Some tests expect $USER to magically be the current user.
@@ -148,11 +149,6 @@ any small or embedded system.")
;; Delete tests that expect a root or 0 user to exist.
(substitute* "tests/id.test"
(("^testing .*[ \\(]root.*") ""))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "make"
- (string-append "PREFIX=" #$output)
- "install")))
(add-after 'install 'remove-usr-directory
(lambda* (#:key outputs #:allow-other-keys)
(delete-file-recursively (string-append #$output "/usr")))))