aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-07-08 00:03:17 -0400
committerVagrant Cascadian <vagrant@debian.org>2023-07-19 22:54:34 -0700
commitffbcc113df02293e1676310dbf3bfb23df8cae10 (patch)
tree4a17cbb597eac4fb1ab34503052ed3d165251424 /gnu/packages/bootloaders.scm
parented5dc3a25d858a394bb7db937a51d866c3cdc6ed (diff)
downloadguix-ffbcc113df02293e1676310dbf3bfb23df8cae10.tar
guix-ffbcc113df02293e1676310dbf3bfb23df8cae10.tar.gz
gnu: Add python-u-boot-pylib.
* gnu/packages/bootloaders.scm (python-u-boot-pylib): New variable. * gnu/packages/patches/u-boot-fix-u-boot-lib-build.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: Vagrant Cascadian <vagrant@debian.org>
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index ea69fc890b..8afb2c3293 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -655,7 +655,8 @@ tree binary files. These are board description files used by Linux and BSD.")
%u-boot-allow-disabling-openssl-patch
%u-boot-sifive-prevent-relocating-initrd-fdt
%u-boot-rk3399-enable-emmc-phy-patch
- (search-patch "u-boot-fix-build-python-3.10.patch")))
+ (search-patch "u-boot-fix-build-python-3.10.patch")
+ (search-patch "u-boot-fix-u-boot-lib-build.patch")))
(method url-fetch)
(uri (string-append
"https://ftp.denx.de/pub/u-boot/"
@@ -841,6 +842,26 @@ CONFIG_TOOLS_LIBCRYPTO=n")
" This package provides board-independent tools "
"of U-Boot."))))
+(define-public python-u-boot-pylib
+ (package
+ (inherit u-boot)
+ (name "python-u-boot-pylib")
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "tools/u_boot_pylib")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "./u_boot_pylib")))))))
+ (synopsis "U-Boot Python library")
+ (description "This package provides common Python code used by some of the
+commands part of the U-Boot project, such as Patman.")))
+
;;; This is packaged separately, as it can be used in other contexts than for
;;; U-Boot development.
(define-public patman