aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-15 19:18:50 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-18 21:04:23 -0500
commit680a7683848185e51f25dee957c5c9ab93605ce1 (patch)
tree127379843abeb8f9fdfa5ce5531fb115253a438f /gnu/packages/bootloaders.scm
parent64e526c3741e62926fe01be66472720cf67d52d8 (diff)
downloadguix-680a7683848185e51f25dee957c5c9ab93605ce1.tar
guix-680a7683848185e51f25dee957c5c9ab93605ce1.tar.gz
gnu: u-boot: Reduce the number of native inputs.
The extra python inputs are only needed for running the u-boot-test-tools test suite. This lowers the requirements for cross-building the various u-boot packages. * gnu/packages/bootloaders.scm (u-boot) [native-inputs]: Delete bc. Move python-coverage, python-pycryptodomex and python-pytest to... * gnu/packages/bootloaders.scm (u-boot-tools) [native-inputs]: ... here. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index b17f8b1a9f..7ec26dda05 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -662,8 +662,7 @@ tree binary files. These are board description files used by Linux and BSD.")
"1y5x8vxdgsqdqlsvq01mn8lmw53fqairkhvhhjx83hjva0m4id2h"))))
(build-system gnu-build-system)
(native-inputs
- (list bc
- bison
+ (list bison
dtc
gnutls
flex
@@ -672,9 +671,6 @@ tree binary files. These are board description files used by Linux and BSD.")
perl
pkg-config ;for 'make menuconfig'
python
- python-coverage
- python-pycryptodomex
- python-pytest
swig
(list util-linux "lib")))
(home-page "https://www.denx.de/wiki/U-Boot/")
@@ -725,7 +721,7 @@ Info manual.")))
(name "u-boot-tools")
(native-inputs
(modify-inputs (package-native-inputs u-boot)
- (prepend sdl2)))
+ (prepend python-coverage python-pycryptodomex python-pytest sdl2)))
(arguments
`(#:make-flags '("HOSTCC=gcc")
#:test-target "tcheck"