aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-05 23:22:47 +0200
committerMarius Bakke <marius@gnu.org>2022-07-06 00:35:17 +0200
commitf12ca428b866c25a3cd9740d9e471e06b8bcaef3 (patch)
treeaa817254fc903ab4844775a0d6a7efa9d6767340 /gnu/packages/boost.scm
parent4fc61750733ab0f4082da2d94ad04faba2eb34a4 (diff)
downloadguix-f12ca428b866c25a3cd9740d9e471e06b8bcaef3.tar
guix-f12ca428b866c25a3cd9740d9e471e06b8bcaef3.tar.gz
gnu: Boost: Avoid usage of 'this-package-input'.
* gnu/packages/boost.scm (boost)[arguments]: Use SEARCH-INPUT-FILE instead of THIS-PACKAGE-INPUT & co. (boost-for-mysql)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm28
1 files changed, 16 insertions, 12 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 1e6881b9ca..bb8789bc28 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -126,9 +126,9 @@
#~(modify-phases %standard-phases
(delete 'bootstrap)
(replace 'configure
- (lambda _
- (let ((icu #$(this-package-input "icu4c"))
- (python #$(this-package-input "python-minimal-wrapper")))
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((icu (dirname (dirname (search-input-file
+ inputs "bin/uconv")))))
(substitute* '("libs/config/configure"
"libs/spirit/classic/phoenix/test/runtest.sh"
"tools/build/src/engine/execunix.cpp")
@@ -158,11 +158,14 @@
;; Ditto for Python.
#$@(if (%current-target-system)
#~()
- #~((string-append "--with-python-root=" python)
- (string-append "--with-python=" python
- "/bin/python")
- (string-append "--with-python-version="
- (python-version python))))
+ #~((let ((python (dirname (dirname (search-input-file
+ inputs
+ "bin/python")))))
+ (string-append "--with-python-root=" python)
+ (string-append "--with-python=" python
+ "/bin/python")
+ (string-append "--with-python-version="
+ (python-version python)))))
"--with-toolset=gcc"))))
(replace 'build
(lambda* (#:key make-flags #:allow-other-keys)
@@ -178,9 +181,9 @@
(lambda* (#:key make-flags inputs outputs #:allow-other-keys)
(let* ((static? (member "link=static" make-flags))
(libext (if static? ".a" ".so"))
- (python-version (python-version
- #$(this-package-input
- "python-minimal-wrapper")))
+ (python (dirname (dirname (search-input-file
+ inputs "bin/python"))))
+ (python-version (python-version python))
(libboost_pythonNN
(string-append "libboost_python"
(string-join (string-split
@@ -318,7 +321,8 @@ across a broad spectrum of applications.")
#~(modify-phases #$phases
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((icu #$(this-package-input "icu4c")))
+ (let ((icu (dirname (dirname (search-input-file
+ inputs "bin/uconv")))))
(substitute* (append
(find-files "tools/build/src/engine/" "execunix\\.c.*")
'("libs/config/configure"