aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-21 09:05:03 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-22 22:56:22 +0200
commit5e8e9bcd25e7bfe945e6e31778e156b796bbc131 (patch)
tree91b4a9938b7a255823573eecd0aee8afe4756e47 /gnu/packages/bittorrent.scm
parente5c3cf139da2f147d6da67f587a482e6ed7d9cde (diff)
downloadguix-5e8e9bcd25e7bfe945e6e31778e156b796bbc131.tar
guix-5e8e9bcd25e7bfe945e6e31778e156b796bbc131.tar.gz
gnu: aria2: Unbundle wslay.
* gnu/packages/bittorrent.scm (aria2)[source]: Add snippet to delete configure script and remove bundled dependency. Add a patch. [native-inputs]: Add autoconf, automake, gettext-minimal, libtool. [inputs]: Add wslay. * gnu/packages/patches/aria2-unbundle-wslay.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: I92390a872454726ff9587518bb535d2105c44ef3
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 5b06041bdc..6f75a92cff 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -78,6 +78,7 @@
#:use-module (gnu packages sqlite)
#:use-module (gnu packages ssh)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages web)
#:use-module (gnu packages xml))
(define-public transmission
@@ -293,7 +294,12 @@ Transmission BitTorrent daemon.")
"/aria2-" version ".tar.xz"))
(sha256
(base32
- "0sxng4pynhj2qinranpv6wyzys3d42kz1gg2nrn63sw5f2nj1930"))))
+ "0sxng4pynhj2qinranpv6wyzys3d42kz1gg2nrn63sw5f2nj1930"))
+ (patches (search-patches "aria2-unbundle-wslay.patch"))
+ (snippet
+ #~(begin (use-modules (guix build utils))
+ (delete-file-recursively "deps")
+ (delete-file "configure")))))
(build-system gnu-build-system)
(arguments
(list
@@ -312,7 +318,11 @@ Transmission BitTorrent daemon.")
(("CPPUNIT_TEST_SUITE_REGISTRATION\\(LpdMessageReceiverTest\\);" text)
(string-append "// " text))))))))
(native-inputs
- (list cppunit ; for the tests
+ (list autoconf ; since we adjusted configure.ac
+ automake
+ gettext-minimal
+ libtool
+ cppunit ; for the tests
pkg-config))
(inputs
(list c-ares
@@ -322,6 +332,7 @@ Transmission BitTorrent daemon.")
libxml2
nettle
sqlite
+ wslay
zlib))
(home-page "https://aria2.github.io/")
(synopsis "Utility for parallel downloading files")