aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorSimon Tournier <zimon.toutoune@gmail.com>2024-04-08 14:49:56 +0200
committerChristopher Baines <mail@cbaines.net>2024-04-09 17:04:02 +0100
commitcf29c427e90bd82556addf67885c276e067ce121 (patch)
treec67d19e3b31d88cfd178d4bb859bca41d77739b7 /gnu/packages/bioinformatics.scm
parentac3f7bad6768283a6a9e3739b9e893adcf03556e (diff)
downloadguix-cf29c427e90bd82556addf67885c276e067ce121.tar
guix-cf29c427e90bd82556addf67885c276e067ce121.tar.gz
gnu: python-deeptools: Update to 3.5.5.
* gnu/packages/bioinformatics.scm (python-deeptools): Update to 3.5.5. [build-system]: Replace by pyproject-build-system. [arguments]: Add phase that fixes 'test/test_tools.py'. Change-Id: Ibb51939275c96df2c4a1e248a03d683f2f4904ac Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm23
1 files changed, 19 insertions, 4 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7861987704..452ec1d829 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4615,7 +4615,7 @@ interval trees with associated meta-data. It is primarily used by the
(define-public python-deeptools
(package
(name "python-deeptools")
- (version "3.4.3")
+ (version "3.5.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4624,8 +4624,23 @@ interval trees with associated meta-data. It is primarily used by the
(file-name (git-file-name name version))
(sha256
(base32
- "0l09vyynz6s6w7fnyd94rpys4a6aja6kp4gli64pngdxdz3md1nl"))))
- (build-system python-build-system)
+ "0mgcs03amrd5157drbm6ikdg0m0szrn9xbflariz2zrrnqpsai6s"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-test
+ (lambda _
+ (substitute* "deeptools/test/test_tools.py"
+ (("e_ver = _p")
+ "e_ver = \".\" + _p + \"-real\""))
+ (substitute* "deeptools/multiBigwigSummary.py"
+ (("version='multiBigwigSummary")
+ "version='%(prog)s"))
+ (substitute* "deeptools/plotCoverage.py"
+ (("version='plotCoverage")
+ "version='%(prog)s")))))))
(native-inputs
(list python-mock python-nose))
(propagated-inputs
@@ -4637,7 +4652,7 @@ interval trees with associated meta-data. It is primarily used by the
python-pysam
python-scipy
python-deeptoolsintervals
- python-plotly-2.4.1))
+ python-plotly))
(home-page "https://pypi.org/project/deepTools/")
(synopsis "Useful tools for exploring deep sequencing data")
(description "This package addresses the challenge of handling large amounts