aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2024-04-23 16:23:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-06 11:38:17 +0200
commit57769fb0b34d65220b6234c78a7fa45b8593b2ab (patch)
tree2f45fba0449afece9b405b2fb0e8f9cd10403c89 /gnu/packages/bioinformatics.scm
parentfc51a747faa36f10f847ff33c0de06a152e49b50 (diff)
downloadguix-57769fb0b34d65220b6234c78a7fa45b8593b2ab.tar
guix-57769fb0b34d65220b6234c78a7fa45b8593b2ab.tar.gz
gnu: Add r-seraster.
* gnu/packages/bioinformatics.scm (r-seraster): New variable. Change-Id: I9f9fd24a9aa563f7c74154e613b85dee46bdcf79
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5775d01c8a..a772229acb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13330,6 +13330,45 @@ bound and non bound genomic regions to accurately identify transcription
factors bound at the specific regions.")
(license license:gpl2+)))
+(define-public r-seraster
+ ;; There are no tags or releases.
+ (let ((commit "4fdc1ffe5d3feb65de9880329d221cf276b393a1")
+ (revision "1"))
+ (package
+ (name "r-seraster")
+ (version (git-version "0.99.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JEFworks-Lab/SEraster")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0y33lk8q0h9nfzmf7slxxvw3l0djassp4l63nsjpm3p6z4pah5s4"))))
+ (properties `((upstream-name . "SEraster")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biocparallel
+ r-ggplot2
+ r-matrix
+ r-rearrr
+ r-sf
+ r-spatialexperiment
+ r-summarizedexperiment))
+ (home-page "https://github.com/JEFworks-Lab/SEraster")
+ (synopsis
+ "Rasterization framework for scalable spatial omics data analysis")
+ (description
+ "This package is a rasterization preprocessing framework that aggregates
+cellular information into spatial pixels to reduce resource requirements for
+spatial omics data analysis. SEraster reduces the number of points in spatial
+omics datasets for downstream analysis through a process of rasterization where
+single cells gene expression or cell-type labels are aggregated into equally
+sized pixels based on a user-defined resolution. SEraster can be incorporated
+with other packages to conduct downstream analyses for spatial omics datasets,
+such as detecting spatially variable genes.")
+ (license license:gpl3))))
+
(define-public emboss
(package
(name "emboss")