aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2023-10-22 20:21:34 +0100
committerArun Isaac <arunisaac@systemreboot.net>2024-02-22 13:02:42 +0000
commit4e6b7f4c4505ce0a92544207e772d349c54dcc29 (patch)
treefdadfa9392b7bd89453d14e2ff590269329d083c /gnu/packages/bioinformatics.scm
parent0728b45295c8961c73cfbb55cc370c1a41279a8e (diff)
downloadguix-4e6b7f4c4505ce0a92544207e772d349c54dcc29.tar
guix-4e6b7f4c4505ce0a92544207e772d349c54dcc29.tar.gz
gnu: Add python-cwl-upgrader.
* gnu/packages/bioinformatics.scm (python-cwl-upgrader): New variable. Change-Id: I2022239840e9fe9e745689ef8b8bf4279be2ff9e Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5ef83e73ab..765a5a2b4c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5158,6 +5158,30 @@ implementation for a very opinionated @acronym{CWL, Common Workflow Language}
code formatter. It outputs CWL in a standardized YAML format.")
(license license:asl2.0)))
+(define-public python-cwl-upgrader
+ (package
+ (name "python-cwl-upgrader")
+ (version "1.2.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cwl-upgrader" version))
+ (sha256
+ (base32
+ "12j6z8nvwnzjjyypz59hwj5hmrcri2r6aknw52n9dbj6lbzbdd2p"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest))
+ (propagated-inputs
+ (list python-ruamel.yaml
+ python-schema-salad))
+ (home-page "https://github.com/common-workflow-language/cwl-upgrader")
+ (synopsis "CWL document upgrader")
+ (description "@code{python-cwl-upgrader} is a standalone upgrader for
+@acronym{CWL, Common Workflow Language} documents from version draft-3, v1.0,
+and v1.1 to v1.2.")
+ (license license:asl2.0)))
+
(define-public cwltool
(package
(name "cwltool")