aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-09-18 05:39:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-09-18 10:25:26 +0200
commit1c8e159335c3723194cd0e5357c89abb8d4edf13 (patch)
treefae97ce27d5272e316d53656b51dcd2fe0008eb4 /gnu/packages/bioinformatics.scm
parent30e5484f35cfb0f6b00ca317c1fc360002ffb8c3 (diff)
downloadguix-1c8e159335c3723194cd0e5357c89abb8d4edf13.tar
guix-1c8e159335c3723194cd0e5357c89abb8d4edf13.tar.gz
gnu: python-plastid: Patch it for python 3.10.
* gnu/packages/bioinformatics.scm (python-plastid)[arguments]: Add new phase 'patch-for-python-3.10. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c78f017a24..b909cd5ee0 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3787,6 +3787,13 @@ UCSC genome browser.")
"-xf" (assoc-ref inputs "test-data"))
;; This one requires bowtie-build
(delete-file "plastid/test/functional/test_crossmap.py")))
+ (add-after 'unpack 'patch-for-python-3.10
+ (lambda _
+ ;; Some classes were moved from collections to collections.abc
+ ;; in Python 3.10.
+ (substitute* "plastid/readers/bigbed.pyx"
+ ((", Iterable")
+ "\nfrom collections.abc import Iterable"))))
(add-before 'check 'build-extensions
(lambda _
;; Cython extensions have to be built before running the tests.