aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-19 14:37:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-19 14:37:54 +0200
commitb4cfd40aaee4477382f6a28aa939a304bf92f894 (patch)
tree74881159b6e8e89f7a769eb1647e37371828d210 /gnu/packages/bioconductor.scm
parent1b48d723bd70b90b8526697debb1805994cbe431 (diff)
downloadguix-b4cfd40aaee4477382f6a28aa939a304bf92f894.tar
guix-b4cfd40aaee4477382f6a28aa939a304bf92f894.tar.gz
gnu: Add r-enhancedvolcano.
* gnu/packages/bioconductor.scm (r-enhancedvolcano): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 4f1a4d61b1..9d924c5429 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6677,6 +6677,34 @@ other types of genomic data that produce counts, including ChIP-seq, SAGE and
CAGE.")
(license license:gpl2+)))
+(define-public r-enhancedvolcano
+ (package
+ (name "r-enhancedvolcano")
+ (version "1.18.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "EnhancedVolcano" version))
+ (sha256
+ (base32
+ "1mcyhgdvfmkkh0rlhf51an7j1zi96lqdhifki2aqmlx0lqvg4qxq"))))
+ (properties `((upstream-name . "EnhancedVolcano")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ggplot2 r-ggrepel))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/kevinblighe/EnhancedVolcano")
+ (synopsis
+ "Publication-ready volcano plots with enhanced coloring and labeling")
+ (description
+ "Volcano plots represent a useful way to visualise the results of
+differential expression analyses. This package provides a highly-configurable
+function that produces publication-ready volcano plots. EnhancedVolcano will
+attempt to fit as many point labels in the plot window as possible, thus
+avoiding clogging up the plot with labels that could not otherwise have been
+read. Other functionality allows the user to identify up to 4 different types
+of attributes in the same plot space via color, shape, size, and shade
+parameter configurations.")
+ (license license:gpl3)))
+
(define-public r-enmix
(package
(name "r-enmix")