aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-19 15:13:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-19 15:29:22 +0200
commit3132fcf7f8e9dda748e3e395c83adfc1de70e52e (patch)
treecf449c446aa694bbc9dbd2121ee96a2d917c303c /gnu/packages/bioconductor.scm
parent72e6324b4ae5a85cbcd08548a5aecdaf390996bd (diff)
downloadguix-3132fcf7f8e9dda748e3e395c83adfc1de70e52e.tar
guix-3132fcf7f8e9dda748e3e395c83adfc1de70e52e.tar.gz
gnu: Add r-globalancova.
* gnu/packages/bioconductor.scm (r-globalancova): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1cef5bb0d5..e46a9175fa 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -7157,6 +7157,38 @@ profiles and assignment of a status (gain, normal or loss) to each chromosomal
regions identified.")
(license license:gpl2)))
+(define-public r-globalancova
+ (package
+ (name "r-globalancova")
+ (version "4.18.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "GlobalAncova" version))
+ (sha256
+ (base32
+ "1fld18rmi6rqm2nr549a4740w1iq3mf5df67v9ba6h42r4abs1ar"))))
+ (properties `((upstream-name . "GlobalAncova")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-annotate
+ r-annotationdbi
+ r-biobase
+ r-corpcor
+ r-dendextend
+ r-globaltest
+ r-gseabase
+ r-vgam))
+ (home-page "https://bioconductor.org/packages/GlobalAncova")
+ (synopsis "Global test for groups of variables via model comparisons")
+ (description
+ "This package supports the computation of an F-test for the association
+between expression values and clinical entities. In many cases a two way
+layout with gene and a dichotomous group as factors will be considered.
+However, adjustment for other covariates and the analysis of arbitrary
+clinical variables, interactions, gene co-expression, time series data and so
+on is also possible. The test is carried out by comparison of corresponding
+linear models via the extra sum of squares principle.")
+ (license license:gpl2+)))
+
(define-public r-globaltest
(package
(name "r-globaltest")