aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/benchmark.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-06 21:55:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-06 21:55:14 +0100
commit61e265d2946a72382887f8e966f5b644affc37ca (patch)
tree59ee18dfbd69c39e457a63f01ecd3a8ab5930c8a /gnu/packages/benchmark.scm
parent8035819f4c93e1be4a4b7d6d015362461a00865c (diff)
downloadguix-61e265d2946a72382887f8e966f5b644affc37ca.tar
guix-61e265d2946a72382887f8e966f5b644affc37ca.tar.gz
gnu: Add multitime.
* gnu/packages/benchmark.scm (multitime): New variable.
Diffstat (limited to 'gnu/packages/benchmark.scm')
-rw-r--r--gnu/packages/benchmark.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index 43d42b37ad..f4bad73dc7 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Dave Love <fx@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
@@ -168,3 +168,28 @@ Efficiency of the MPI implementation.
(license license:cpl1.0)))
(define-public imb-openmpi (imb openmpi))
+
+(define-public multitime
+ (package
+ (name "multitime")
+ (version "1.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://tratt.net/laurie/src/"
+ "multitime/releases/"
+ "multitime-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0iyfsdrbyqa7a4ifrh19l9a48hgv7ld6m0d8yf9bkl12q0qw91fx"))))
+ (build-system gnu-build-system)
+ (arguments '(#:tests? #f)) ; there are no tests
+ (home-page "https://tratt.net/laurie/src/multitime/")
+ (synopsis "Time command execution over multiple executions")
+ (description
+ "The @code{time} utility is a simple and often effective way of measuring
+how long a command takes to run (wall time). Unfortunately, running a command
+once can give misleading timings. @code{multitime} is, in essence, a simple
+extension to @code{time} which runs a command multiple times and prints the
+timing means, standard deviations, mins, medians, and maxes having done so.
+This can give a much better understanding of the command's performance.")
+ (license license:expat)))