aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-02 15:42:36 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-20 10:11:32 +0200
commitf719a4086cabfadfd014e814e1cef6ae4dae94d1 (patch)
treeaf2b921590e700f32be7662daccf2b6b95974f62 /gnu/packages/base.scm
parente4721f7472ba9bc1d025a52edc96a568e9b574b8 (diff)
downloadguix-f719a4086cabfadfd014e814e1cef6ae4dae94d1.tar
guix-f719a4086cabfadfd014e814e1cef6ae4dae94d1.tar.gz
gnu: grep: Update hanging and failing tests on the Hurd.
* gnu/packages/base.scm (grep)[arguments]: When building natively on the Hurd, remove Rename phase 'skip-triple-backref-test' to 'skip-tests'. Remove "tests/triple-backref" as it now passes. Add the hanging "tests/hash-collision-perf" test, and the failing "tests/file" test.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm24
1 files changed, 10 insertions, 14 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index e941853d20..f1b027b0dc 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -134,21 +134,17 @@ command-line arguments, multiple languages, and so on.")
(string-append bin "/fgrep"))
(("^exec grep")
(string-append "exec " bin "/grep"))))))
- ,@(if (target-hurd?)
- '((add-before 'check 'skip-triple-backref-test
+ ,@(if (system-hurd?)
+ '((add-before 'check 'skip-test
(lambda _
- ;; This test is marked as malfunctioning on glibc systems
- ;; due to
- ;; <https://sourceware.org/bugzilla/show_bug.cgi?id=11053>
- ;; and it triggers a segfault with glibc 2.33 on GNU/Hurd.
- ;; Skip it.
- (substitute* "tests/triple-backref"
- (("^warn_" all)
- (string-append "exit 77\n" all))))))
- '()))
- #:make-flags ,(if (target-hurd?)
- ''("XFAIL_TESTS=test-perror2 equiv-classes") ;XXX
- ''())))
+ (substitute*
+ ;; This test hangs
+ '("tests/hash-collision-perf"
+ ;; This test fails
+ "tests/file")
+ (("^#!.*" all)
+ (string-append all "exit 77;\n"))))))
+ '()))))
(synopsis "Print lines matching a pattern")
(description
"grep is a tool for finding text inside files. Text is found by