aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-02-21 20:52:29 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:48 +0200
commitf6aa4bd9608bb4d1a2acae7ce000bca4bfb220b6 (patch)
tree268c769dd165193281f323ad92b5e10743f72fe0 /gnu/packages/base.scm
parent3c690043ce9ab51c126f506e240bc8659c016c7e (diff)
downloadguix-f6aa4bd9608bb4d1a2acae7ce000bca4bfb220b6.tar
guix-f6aa4bd9608bb4d1a2acae7ce000bca4bfb220b6.tar.gz
gnu: glibc-2.33: Fix source build.
* gnu/packages/base.scm (glibc-2.33)[source]: Use patches from glibc-2.35. Change-Id: Idfcad60a39bdfd54d6126c1b440c8915ec2d4df2
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 0c4a9a08ed..b82f2e3142 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2014 Alex Kost <alezost@gmail.com>
;;; Copyright © 2014, 2015 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2016, 2017, 2019-2023 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016, 2020, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2016, 2020, 2023, 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016, 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2017, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -1201,12 +1201,14 @@ with the Linux kernel.")
"1zvp0qdfbdyqrzydz18d9zg3n5ygy8ps7cmny1bvsp8h1q05c99f"))
(patches
(cons (search-patch "glibc-2.33-riscv64-miscompilation.patch")
- ;; Remove a patch that's become irrelevant and that does not
- ;; apply to this version.
- (remove (lambda (patch)
- (string=? (basename patch)
- "glibc-hurd-clock_gettime_monotonic.patch"))
- (origin-patches (package-source glibc)))))))
+ ;; Remove patches that are irrelevant or do not apply to
+ ;; this version.
+ (remove
+ (lambda (patch)
+ (member (basename patch)
+ '("glibc-2.35-CVE-2023-4911.patch"
+ "glibc-hurd-clock_gettime_monotonic.patch")))
+ (origin-patches (package-source glibc-2.35)))))))
(arguments
(substitute-keyword-arguments (package-arguments glibc)
((#:configure-flags flags ''())