aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2022-11-02 21:38:55 +0100
committerChristopher Baines <mail@cbaines.net>2022-11-02 21:38:55 +0100
commite26b529b1ab4671a971f0a4b45d19abe55134475 (patch)
treee5970a2e259791ca19a398fab7bbfaee9bc8fc38 /gnu/packages/base.scm
parentdb670af37d33c0b8bc85f0180ac08d1eb34ad19d (diff)
downloadguix-e26b529b1ab4671a971f0a4b45d19abe55134475.tar
guix-e26b529b1ab4671a971f0a4b45d19abe55134475.tar.gz
gnu: coreutils: Disable the test-tls tests on the hurd.
These tests seem to lead to both consistent and inconsistent failures, so marking them as XFAIL as is done with some other tests doesn't help. So this commit means that they're skipped. * gnu/packages/base.scm (coreutils)[arguments]: Disable the test-tls tests on the hurd.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 5674036318..bf6435585e 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -415,7 +415,13 @@ used to apply commands with arbitrarily long arguments.")
,@(if (hurd-target?)
'((substitute* "Makefile.in"
;; this test hangs
- (("^ *tests/misc/timeout-group.sh.*") "")))
+ (("^ *tests/misc/timeout-group.sh.*") ""))
+ (substitute* "gnulib-tests/Makefile.in"
+ ;; This test sometimes fails and sometimes
+ ;; passes, but it does this consistently, so
+ ;; there might be some environmental factor
+ ;; here
+ ((" test-tls\\$\\(EXEEXT\\) ") " ")))
'())
(substitute* "Makefile.in"
;; fails on filesystems where inotify cannot be used,