aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-14 21:54:26 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-02-14 21:54:26 +0200
commita832b4180ec3ea833ff4fde36c24eb215c043677 (patch)
treea0f88d36adf2f823b6098a120d8ee06fde22ba8c /gnu/packages/base.scm
parentda7d615629184631368789edef0ab81294a4bdf9 (diff)
downloadguix-a832b4180ec3ea833ff4fde36c24eb215c043677.tar
guix-a832b4180ec3ea833ff4fde36c24eb215c043677.tar.gz
gnu: tar: Actually fix test suite on 32-bit systems.
This is a follow-up to 87423addf503fc2b44dc2f863d6db1712d67c55c. * gnu/packages/base.scm (tar)[arguments]: Actually skip the broken test on 32-bit systems, not run ONLY that test.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 2a622b61a3..b9fb09272d 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -237,7 +237,7 @@ implementation offers several extensions over the standard utility.")
;; tar-1.34 isn't aware of 64-bit time_t and upstream suggests
;; skipping the test for this release on 32-bit systems.
((not (target-64bit?))
- '(#:make-flags (list "TESTSUITEFLAGS= -k 'tricky time stamps'")))
+ '(#:make-flags (list "TESTSUITEFLAGS= -k '!tricky time stamps'")))
(else '()))
#:phases (modify-phases %standard-phases
(add-before 'build 'set-shell-file-name