aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-02-10 22:37:08 +0100
committerLudovic Courtès <ludo@gnu.org>2014-02-10 22:37:08 +0100
commit99662b8dbf420d0112f83b7daddcecfb1bcb9bad (patch)
tree4da01ede0efb634b3804968d3bb26c1f9ebe0e81 /gnu/packages/base.scm
parentc2e65167212f15093f672ebc49f3f7d4a51fcd2b (diff)
downloadguix-99662b8dbf420d0112f83b7daddcecfb1bcb9bad.tar
guix-99662b8dbf420d0112f83b7daddcecfb1bcb9bad.tar.gz
gnu: glibc: Upgrade to 2.19.
* gnu/packages/base.scm (glibc): Upgrade to 2.19. Remove 'glibc-make-4.0.patch'. * gnu/packages/patches/glibc-make-4.0.patch: Remove. * gnu-system.am (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index d6f75be238..f0fe5caaa3 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -364,14 +364,14 @@ library for working with executable and object formats is also included.")
(define-public glibc
(package
(name "glibc")
- (version "2.18")
+ (version "2.19")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/glibc/glibc-"
version ".tar.xz"))
(sha256
(base32
- "18spla703zav8dq9fw7rbzkyv9qfisxb26p7amg1x3wjh7iy3d1c"))
+ "18m2dssd6ja5arxmdxinc90xvpqcsnqjfwmjl2as07j0i3srff9d"))
(snippet
;; Disable 'ldconfig' and /etc/ld.so.cache. The latter is
;; required on LFS distros to avoid loading the distro's libc.so
@@ -381,9 +381,7 @@ library for working with executable and object formats is also included.")
"use_ldconfig=no")))
(modules '((guix build utils)))
(imported-modules modules)
- (patches (map search-patch
- '("glibc-ldd-x86_64.patch"
- "glibc-make-4.0.patch")))))
+ (patches (list (search-patch "glibc-ldd-x86_64.patch")))))
(build-system gnu-build-system)
;; Glibc's <limits.h> refers to <linux/limit.h>, for instance, so glibc