aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-11-25 16:17:12 +0100
committerLudovic Courtès <ludo@gnu.org>2023-11-25 16:29:25 +0100
commit95ea1277ae2ebd278bdb51a7887f5ba1116fbc64 (patch)
treeaa6ae1822a089c4e9a00d9e6f76b40149ac5518b /gnu/packages/base.scm
parent5149bf99ba0238b647733399b1a9cbf7da486634 (diff)
downloadguix-95ea1277ae2ebd278bdb51a7887f5ba1116fbc64.tar
guix-95ea1277ae2ebd278bdb51a7887f5ba1116fbc64.tar.gz
gnu: commencement: Use locales for the right libc version on GNU/Hurd.
Fixes <https://issues.guix.gnu.org/66472>. Until now, we were unconditionally using ‘glibc-utf8-locales’, which targets the glibc version used on Linux (2.35) rather than that used on the Hurd (2.37). This would lead to build failures due to the inability to use locale encoding when targeting i586-gnu. * gnu/packages/base.scm (glibc-utf8-locales/hurd): New variable. * gnu/packages/commencement.scm (glibc-utf8-locales-final/hurd): New variable. (%boot5-inputs): Use it when ‘target-hurd?’ returns #t. (%final-inputs): Likewise. Change-Id: I1666d615dffbe3561cf2d9612b85cd31a48a7dcd
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 2d8e9143cd..41aff0ca97 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1512,6 +1512,11 @@ command.")
(delete 'build))))) ; nothing to build
(supported-systems %hurd-systems)))
+(define-public glibc-utf8-locales/hurd
+ ;; Locales for the libc version used on GNU/Hurd.
+ (hidden-package
+ (make-glibc-utf8-locales glibc/hurd)))
+
(define* (libc-for-target #:optional
(target (or (%current-target-system)
(%current-system))))