aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-02-01 14:30:45 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:51 +0200
commit70b2015ec5356cd6c8fd6532750db9cd01f66967 (patch)
tree05247b94e21f4934b15ac111391909cdc00e93d6 /gnu/packages/base.scm
parentc033fb81461a6696d6f22a29c5003486ed212e9e (diff)
downloadguix-70b2015ec5356cd6c8fd6532750db9cd01f66967.tar
guix-70b2015ec5356cd6c8fd6532750db9cd01f66967.tar.gz
gnu: glibc: Update to 2.39.
* gnu/packages/base.scm (glibc): Update it. Remove --enable-crypt as it is no longer included in 2.39. Remove upstreamed patch for hurd. * gnu/packages/patches/glibc-2.38-hurd-ucontext.patch: Remove patch. * gnu/local.mk (dist_patch_DATA): Unregister it. Change-Id: Idf9ae3ff6cbbe45f1c9bfbc2c78a331f118e0129
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 2d8e53faca..68e408494f 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -834,13 +834,13 @@ the store.")
;; version 2.28, GNU/Hurd used a different glibc branch.
(package
(name "glibc")
- (version "2.38")
+ (version "2.39")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/glibc/glibc-" version ".tar.xz"))
(sha256
(base32
- "1lizxxqbfma5zgmcj0gk5iyk171f2nfvdhbv8rjrkcmjk24rk0pv"))
+ "09nrwb0ksbah9k35jchd28xxp2hidilqdgz7b8v5f30pz1yd8yzp"))
(patches (search-patches "glibc-ldd-powerpc.patch"
"glibc-2.38-ldd-x86_64.patch"
"glibc-dl-cache.patch"
@@ -850,7 +850,6 @@ the store.")
"glibc-supported-locales.patch"
"glibc-2.37-hurd-clock_t_centiseconds.patch"
"glibc-2.37-hurd-local-clock_gettime_MONOTONIC.patch"
- "glibc-2.38-hurd-ucontext.patch"
"glibc-hurd-mach-print.patch"
"glibc-hurd-gettyent.patch"
"glibc-hurd-getauxval.patch"))))
@@ -915,10 +914,6 @@ the store.")
"kernel-headers")
"/include")
- ;; Libcrypt and <crypt.h> are deprecated in glibc 2.38 and not
- ;; built by default. Build it to reduce application breakage.
- "--enable-crypt"
-
;; This is the default for most architectures as of GNU libc 2.26,
;; but we specify it explicitly for clarity and consistency. See
;; "kernel-features.h" in the GNU libc for details.
@@ -1181,6 +1176,9 @@ with the Linux kernel.")
"glibc-hurd-gettyent.patch"))))
(arguments
(substitute-keyword-arguments (package-arguments glibc)
+ ((#:configure-flags flags #~'())
+ #~(cons* "--enable-crypt"
+ #$flags))
((#:phases phases)
;; The C.UTF-8 fails to build in glibc 2.35:
;; <https://sourceware.org/bugzilla/show_bug.cgi?id=28861>.