aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-09-15 23:37:32 +0200
committerLudovic Courtès <ludo@gnu.org>2013-09-15 23:37:32 +0200
commit692b93408f9f3ac3e43192fb869de966fa1d1204 (patch)
treebcea42c90755639280b3f85ca24f399e7880f4d1 /gnu/packages/base.scm
parent66018f1c338375796a8a2d5130bae5cdb9a48b5f (diff)
downloadguix-692b93408f9f3ac3e43192fb869de966fa1d1204.tar
guix-692b93408f9f3ac3e43192fb869de966fa1d1204.tar.gz
gnu: glibc: Fix 'ldd' on x86_64.
Reported by Cyril Roelandt at <https://lists.gnu.org/archive/html/guix-devel/2013-09/msg00136.html>. * gnu/packages/patches/glibc-ldd-x86_64.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/base.scm (glibc): Use it.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 3356c078f7..5a32e57535 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -409,7 +409,8 @@ BFD (Binary File Descriptor) library, `gprof', `nm', `strip', etc.")
(arguments
`(#:out-of-source? #t
- #:patches (list (assoc-ref %build-inputs "patch/ld.so.cache"))
+ #:patches (list (assoc-ref %build-inputs "patch/ld.so.cache")
+ (assoc-ref %build-inputs "patch/ldd"))
#:configure-flags
(list "--enable-add-ons"
"--sysconfdir=/etc"
@@ -422,7 +423,6 @@ BFD (Binary File Descriptor) library, `gprof', `nm', `strip', etc.")
(assoc-ref %outputs "locales")
"/share/locale")
-
(string-append "--with-headers="
(assoc-ref %build-inputs "linux-headers")
"/include")
@@ -496,6 +496,8 @@ BFD (Binary File Descriptor) library, `gprof', `nm', `strip', etc.")
(inputs `(("patch/ld.so.cache"
,(search-patch "glibc-no-ld-so-cache.patch"))
+ ("patch/ldd"
+ ,(search-patch "glibc-ldd-x86_64.patch"))
("static-bash" ,(static-package bash-light))))
(synopsis "The GNU C Library")
(description