aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-26 13:48:28 +0200
committerMarius Bakke <marius@gnu.org>2022-06-26 22:58:33 +0200
commit40f96ea6679ab904c4535db9c4ec9c5f994ec484 (patch)
treed79a2974120168e2f50302c155e0870438d4573b /gnu/packages/base.scm
parent6c80f4949fa1a5aa766f7f3834d75463b77cd107 (diff)
downloadguix-40f96ea6679ab904c4535db9c4ec9c5f994ec484.tar
guix-40f96ea6679ab904c4535db9c4ec9c5f994ec484.tar.gz
gnu: binutils: Update to 2.38.
If this commit gives a deja vu, you are not dreaming; see commit 3e3a37b2bcb1f23011fde8626559f83504177889. * gnu/packages/base.scm (binutils): Update to 2.38. [source](patches): Remove obsolete. [arguments]: Add #:make-flags. [properties]: New field. (binutils+documentation): New variable. (binutils-gold): Inherit from BINUTILS+DOCUMENTATION. * gnu/packages/make-bootstrap.scm (%binutils-static)[arguments]: Inherit #:make-flags. * gnu/packages/patches/binutils-2.37-file-descriptor-leak.patch, gnu/packages/patches/binutils-CVE-2021-45078.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm33
1 files changed, 25 insertions, 8 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index b3c4ed27a5..cf640aad25 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2016, 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2017, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
-;;; Copyright © 2017, 2018, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2018, 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019, 2022 Ricardo Wurmus <rekado@elephly.net>
@@ -511,17 +511,15 @@ change. GNU make offers many powerful extensions over the standard utility.")
(define-public binutils
(package
(name "binutils")
- (version "2.37")
+ (version "2.38")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://gnu/binutils/binutils-"
version ".tar.bz2"))
(sha256
- (base32 "1m3b2rdfv1dmdpd0bzg1hy7i8a2qng53szc6livyi3nh6101mz37"))
- (patches (search-patches "binutils-loongson-workaround.patch"
- "binutils-2.37-file-descriptor-leak.patch"
- "binutils-CVE-2021-45078.patch"))))
+ (base32 "1y0fb4qgxaxfyf81x9fqq9w5609mkah0b7wm1f7ab9kpy0fcf3h7"))
+ (patches (search-patches "binutils-loongson-workaround.patch"))))
(build-system gnu-build-system)
(arguments
`(#:out-of-source? #t ;recommended in the README
@@ -550,7 +548,16 @@ change. GNU make offers many powerful extensions over the standard utility.")
"--enable-compressed-debug-sections=all"
"--enable-lto"
"--enable-separate-code"
- "--enable-threads")))
+ "--enable-threads")
+ ;; XXX: binutils 2.38 was released without generated manuals:
+ ;; <https://sourceware.org/bugzilla/show_bug.cgi?id=28909>. To avoid
+ ;; a circular dependency on texinfo, prevent the build system from
+ ;; creating the manuals by calling "true" instead of "makeinfo" ...
+ #:make-flags '("MAKEINFO=true")))
+
+ ;; ... and "hide" this package such that users who install binutils get
+ ;; the version with documentation defined below.
+ (properties '((hidden? . #t)))
(synopsis "Binary utilities: bfd gas gprof ld")
(description
@@ -563,6 +570,16 @@ included.")
(license gpl3+)
(home-page "https://www.gnu.org/software/binutils/")))
+(define-public binutils+documentation
+ (package/inherit binutils
+ (native-inputs
+ (list texinfo))
+ (arguments
+ (substitute-keyword-arguments (package-arguments binutils)
+ ((#:make-flags flags ''())
+ ''())))
+ (properties '())))
+
;; FIXME: ath9k-firmware-htc-binutils.patch do not apply on 2.34 because of a
;; big refactoring of xtensa-modules.c (commit 567607c11fbf7105 upstream).
;; Keep this version around until the patch is updated.
@@ -584,7 +601,7 @@ included.")
(properties '())))
(define-public binutils-gold
- (package/inherit binutils
+ (package/inherit binutils+documentation
(name "binutils-gold")
(arguments
(substitute-keyword-arguments (package-arguments binutils)