aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-19 12:06:01 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-19 15:13:12 +0100
commitdebd03323f190bd214b0ab50aa3ec833d9766912 (patch)
tree370627e28164f1b63cb60d24a0a6b0f4f6071efc /gnu/packages/backup.scm
parentabe7cfc46d2654b60c99fa4d196cda1568da0408 (diff)
downloadguix-debd03323f190bd214b0ab50aa3ec833d9766912.tar
guix-debd03323f190bd214b0ab50aa3ec833d9766912.tar.gz
gnu: restic-rest-server: Update to 0.12.1.
* gnu/packages/backup.scm (restic-rest-server): Update to 0.12.1. [native-inputs]: Remove go-github-com-coreos-go-systemd-activation; add go-github-com-coreos-go-systemd-v22. Change-Id: I5d43b85f8ba340ef0adedc68ec1c0f01dbe062a0
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 5e74439bff..637a873fbf 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -1055,7 +1055,7 @@ precious backup space.
(define-public restic-rest-server
(package
(name "restic-rest-server")
- (version "0.11.0")
+ (version "0.12.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1064,7 +1064,7 @@ precious backup space.
(file-name (git-file-name name version))
(sha256
(base32
- "1nvmxc9x0mlks6yfn66fmwn50k5q83ip4g9vvb0kndzd7hwcyacy"))))
+ "18jk93j91dq4639nml4qnq1fq5j3s67ca3gvfka5aafln8ir8ffk"))))
(build-system go-build-system)
(arguments
(list
@@ -1083,7 +1083,7 @@ precious backup space.
;; "rest-server" is a bit too generic.
(rename-file "bin/rest-server"
"bin/restic-rest-server")))))))
- (native-inputs (list go-github-com-coreos-go-systemd-activation
+ (native-inputs (list go-github-com-coreos-go-systemd-v22
go-github-com-gorilla-handlers
go-github-com-minio-sha256-simd
go-github-com-miolini-datacounter