aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-03-30 22:50:45 +0100
committerLudovic Courtès <ludo@gnu.org>2013-03-30 22:57:05 +0100
commit9be8d7c8cb1b1ee4d1f3ba7360320527199b4a0d (patch)
tree61e08884a237752bc57daf5e4fe441d642d53e16 /gnu/packages/autotools.scm
parenta18eda2747fa2eb962e3288066d2b1a679589ed3 (diff)
downloadguix-9be8d7c8cb1b1ee4d1f3ba7360320527199b4a0d.tar
guix-9be8d7c8cb1b1ee4d1f3ba7360320527199b4a0d.tar.gz
gnu: Define `native-search-paths' for Automake, Guile, and Python.
* gnu/packages/autotools.scm (automake)[native-search-paths]: New field. * gnu/packages/guile.scm (guile-1.8)[native-search-paths]: New field. (guile-2.0)[native-search-paths]: New field. * gnu/packages/python.scm (python)[native-search-paths]: New field.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index bc4dddc01f..114e98f606 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -164,6 +164,11 @@ exec ~a --no-auto-compile \"$0\" \"$@\"
(setenv "SHELL" sh)
(setenv "CONFIG_SHELL" sh)))
%standard-phases)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "ACLOCAL_PATH")
+ (directories '("share/aclocal")))))
+
(home-page "http://www.gnu.org/software/automake/")
(synopsis
"GNU Automake, a GNU standard-compliant makefile generator")