aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-05-26 20:50:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-05-28 22:01:09 +0300
commit1da2834720c99c3707d17e4bf12e409b1a374b29 (patch)
treed7ad6c30e0f4a7b944cc4586d502f30731970278 /gnu/packages/autotools.scm
parent3acb615a3828207d55f52873b669c6917a16e10d (diff)
downloadguix-1da2834720c99c3707d17e4bf12e409b1a374b29.tar
guix-1da2834720c99c3707d17e4bf12e409b1a374b29.tar.gz
gnu: libtool and libltdl: Update to 2.4.7.
* gnu/packages/autotools.scm (libtool, libltdl): Update to 2.4.7. [arguments]: Remove trailing #t from phases. Remove unnecessary file field from find-files. (libltdl)[arguments]: Remove trailing #t. * gnu/packages/patches/libtool-skip-tests2.patch: Update patch.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 0c3152d7f8..a46ac09228 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2015, 2017, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2017 Nikita <nikita@n0.is>
-;;; Copyright © 2017, 2019, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2019, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
@@ -451,14 +451,14 @@ Makefile, simplifying the entire process for the developer.")
(define-public libtool
(package
(name "libtool")
- (version "2.4.6")
+ (version "2.4.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/libtool/libtool-"
version ".tar.xz"))
(sha256
(base32
- "0vxj52zm709125gwv9qqlw02silj8bnjnh4y07arrz60r31ai1vw"))
+ "0pb3l4x37k6fj1lwnpzws55gi3pxl0hx56jm4bzmbrkw0mzj2zsg"))
(patches (search-patches "libtool-skip-tests2.patch"))))
(build-system gnu-build-system)
(propagated-inputs (list m4))
@@ -495,8 +495,7 @@ Makefile, simplifying the entire process for the developer.")
(let ((bash (assoc-ref (or native-inputs inputs) "bash")))
(substitute* "tests/testsuite"
(("/bin/sh")
- (string-append bash "/bin/sh")))
- #t)))
+ (string-append bash "/bin/sh"))))))
;; These files may be copied into source trees by libtoolize,
;; therefore they must not point to store file names that would be
;; leaked with tarballs generated by make dist.
@@ -508,8 +507,7 @@ Makefile, simplifying the entire process for the developer.")
(format #t "restoring shebang on `~a'~%" file)
(substitute* file
(("^#!.*/bin/sh") "#!/bin/sh")))
- (find-files dir ".*"))
- #t))))))
+ (find-files dir))))))))
(synopsis "Generic shared library support tools")
(description
@@ -573,20 +571,20 @@ configuration in nearly all GNU packages (and many others).")
;; Libtool's extensive test suite isn't run.
(package
(name "libltdl")
- (version "2.4.6")
+ (version "2.4.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/libtool/libtool-"
version ".tar.xz"))
(sha256
(base32
- "0vxj52zm709125gwv9qqlw02silj8bnjnh4y07arrz60r31ai1vw"))))
+ "0pb3l4x37k6fj1lwnpzws55gi3pxl0hx56jm4bzmbrkw0mzj2zsg"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--enable-ltdl-install") ;really install it
#:phases (modify-phases %standard-phases
(add-before 'configure 'change-directory
- (lambda _ (chdir "libltdl") #t)))))
+ (lambda _ (chdir "libltdl"))))))
(synopsis "System-independent dlopen wrapper of GNU libtool")
(description (package-description libtool))