aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-13 10:52:54 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-13 10:52:54 +0300
commited3f818b15d88f75e57db1fd107d8b5c995ceef5 (patch)
treec301ae4ce5a2f68b76cc8107160b623573f3849c /gnu/packages/astronomy.scm
parenta0221c342481a650f7e1ad5014a7c473b3165e7a (diff)
downloadguix-ed3f818b15d88f75e57db1fd107d8b5c995ceef5.tar
guix-ed3f818b15d88f75e57db1fd107d8b5c995ceef5.tar.gz
gnu: alfa: Reuse 'check phase.
* gnu/packages/astronomy.scm (alfa)[arguments]: Set test-target. Replace custom 'post-install-check phase with the standard 'check phase. Change-Id: Ic5f77ac3a3a6ef62ce36ad5fa8892db6d0894d04
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index dd90884e12..3701a7e90c 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -130,13 +130,12 @@
#:tests? (not (or (%current-target-system)
;; The test suite consumes all disk space
(target-riscv64?)))
+ #:test-target "fittest"
#:phases #~(modify-phases %standard-phases
(delete 'configure)
(delete 'check)
(add-after 'install 'post-install-check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "make" "fittest")))))))
+ (assoc-ref %standard-phases 'check)))))
(inputs (list cfitsio gfortran))
(home-page "https://nebulousresearch.org/codes/alfa/")
(synopsis "Automated line fitting algorithm")