aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-10-10 11:38:27 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-30 19:32:16 +0000
commit8ad115a2a270beb8b8fe86f4cbf1eee2796543b2 (patch)
tree25afe16210f2b31585647621d4b6bb1748a127cc /gnu/packages/astronomy.scm
parent0f168056462693a3600a43cd5007b88bef27f920 (diff)
downloadguix-8ad115a2a270beb8b8fe86f4cbf1eee2796543b2.tar
guix-8ad115a2a270beb8b8fe86f4cbf1eee2796543b2.tar.gz
gnu: python-sep-pjw: Update to 1.3.6.
* gnu/packages/astronomy.scm (python-sep-pjw): Update to 1.3.6. [phases]{relax-requirements}: Add more relaxation on not yet supported option. [native-inputs]: Add python-setuptools, python-setuptools-scm, and python-wheel. Change-Id: I507ca06def6afaaed70f9b31bb7a960437ba33d0
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm25
1 files changed, 16 insertions, 9 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index a2304ad0ed..fdee039f62 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -5480,26 +5480,33 @@ well as ephemerides services
(define-public python-sep-pjw
(package
(name "python-sep-pjw")
- (version "1.3.5")
+ (version "1.3.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "sep_pjw" version))
(sha256
- (base32 "15jf16zycs1gz6jfkhmj7b8wdcpp8d5ikz15pmfkwq32a8mfdv8m"))))
+ (base32 "0ji3khgswidnnqx34js9fyk39kgh4gvf7q8gk2f7r4acaabzja2v"))))
(build-system pyproject-build-system)
(arguments
- (list #:test-flags #~(list "test.py")
+ (list
+ #:test-flags #~(list "test.py")
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'relax-requirements
- (lambda _
- (substitute* "pyproject.toml"
- ;; numpy>=1.23.5
- (("1.23.5") "1.23.2")))))))
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "pyproject.toml"
+ ;; numpy>=1.23.5
+ (("1.23.5") "1.23.2")
+ ;; TypeError: Configuration.__init__() got an unexpected
+ ;; keyword argument 'version_file'
+ (("version_file = .*") "")))))))
(native-inputs
(list python-cython
- python-pytest))
+ python-pytest
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(propagated-inputs
(list python-numpy))
(home-page "https://github.com/PJ-Watson/sep-pjw")