aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-10-10 11:06:31 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-30 19:32:16 +0000
commit1c8b7745848e022bc719ae4ceba5973737e47bc3 (patch)
treef5cfc226d7d9f3bf9c3ef9795fbdca502db64341 /gnu/packages/astronomy.scm
parent90f49faac15f6e4d26fc45594d57c9c703e43946 (diff)
downloadguix-1c8b7745848e022bc719ae4ceba5973737e47bc3.tar
guix-1c8b7745848e022bc719ae4ceba5973737e47bc3.tar.gz
gnu: python-pyregion: Update to 2.3.0.
* gnu/packages/astronomy.scm (python-pyregion): Update to 2.3.0. [arguments] <#:phases>: Add 'create-setup.py phase. [native-inputs]: Add python-extension-helpers, python-pytest-astropy, and python-setuptools. Change-Id: I4c114a5ec51a7dae2197f60579f1e63597c23ea7
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm20
1 files changed, 17 insertions, 3 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index edfa36a61f..2b2ddaf68e 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -5253,28 +5253,42 @@ N-Chilada and RAMSES AMR outputs.")
(define-public python-pyregion
(package
(name "python-pyregion")
- (version "2.2.0")
+ (version "2.3.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyregion" version))
(sha256
- (base32 "0l7qb7r8fnv46mdih4m5b8jaxixgpw6m7v37dpikjkblgh0vigaw"))))
+ (base32 "09a98v3zk1vdjns1q64al58mapr4cns3nlnyi6b26wqi888qfjg8"))))
(build-system pyproject-build-system)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
+ ;; setup.py was removed in b26ec4fe88e29447dc8391fcdef7082a4f7876ce
+ ;; TODO: Check how to implement it in python-build-system.
+ (add-after 'unpack 'create-setup.py
+ (lambda _
+ (call-with-output-file "setup.py"
+ (lambda (port)
+ (format port "from setuptools import setup
+from extension_helpers import get_extensions
+setup(ext_modules=get_extensions())")))))
(add-before 'check 'build-extensions
(lambda _
;; Cython extensions have to be built before running the tests.
(invoke "python" "setup.py" "build_ext" "--inplace"))))))
(propagated-inputs
- (list python-astropy python-numpy python-pyparsing))
+ (list python-astropy
+ python-numpy
+ python-pyparsing))
(native-inputs
(list python-cython
+ python-extension-helpers
python-pytest
+ python-pytest-astropy
python-pytest-astropy-header
+ python-setuptools
python-setuptools-scm))
(home-page "https://github.com/astropy/pyregion")
(synopsis "Python parser for ds9 region files")