aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/assembly.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:01 +0200
commiteb12f3fd8bee99920118ec802ffbac8f1ab676b9 (patch)
treeb3e4ad83abe8de10595e579fc30f3dd868ede935 /gnu/packages/assembly.scm
parent2103e7c0fcb3509c5d03963594b847524b0003d6 (diff)
downloadguix-eb12f3fd8bee99920118ec802ffbac8f1ab676b9.tar
guix-eb12f3fd8bee99920118ec802ffbac8f1ab676b9.tar.gz
gnu: wla-dx: Use G-expressions.
* gnu/packages/assembly.scm (wla-dx)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/assembly.scm')
-rw-r--r--gnu/packages/assembly.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 488d0725eb..42c95876f7 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -359,16 +359,17 @@ package for the Game Boy and Game Boy Color. It consists of:
(build-system cmake-build-system)
(native-inputs (list python-sphinx)) ; to generate man pages
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'copy-tests-to-build-directory
- (lambda _
- (copy-recursively "../source/tests" "tests")))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (let ((sh (which "sh")))
- (when tests?
- (invoke sh "../source/run_tests.sh"))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'copy-tests-to-build-directory
+ (lambda _
+ (copy-recursively "../source/tests" "tests")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (let ((sh (which "sh")))
+ (when tests?
+ (invoke sh "../source/run_tests.sh"))))))))
(home-page "https://github.com/vhelin/wla-dx")
(synopsis "Assemblers for various processors")
(description "WLA DX is a set of tools to assemble assembly files to