aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/aspell.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-12 13:14:53 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-12 15:26:20 +0100
commit8dbd8e426c7d7e4c14f9e787e68fd9d00edccb1e (patch)
tree41319b95588508bf54adacf168836971b5ad20de /gnu/packages/aspell.scm
parentb4ed7c3e8d7b2915ab9ea7e369bc1bdd05f41ad1 (diff)
downloadguix-8dbd8e426c7d7e4c14f9e787e68fd9d00edccb1e.tar
guix-8dbd8e426c7d7e4c14f9e787e68fd9d00edccb1e.tar.gz
gnu: aspell-dict-it: Update to 2.4-20070901-0.
* gnu/packages/aspell.scm (aspell-dict-it): Update to 2.4-20070901-0.
Diffstat (limited to 'gnu/packages/aspell.scm')
-rw-r--r--gnu/packages/aspell.scm26
1 files changed, 20 insertions, 6 deletions
diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index ca9fc8eda5..dd006e8184 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Christopher Andersson <christopher@8bits.nu>
;;; Copyright © 2016 Theodoros Foradis <theodoros@foradis.org>
-;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -197,11 +197,25 @@ dictionaries, including personal ones.")
"13bhbghx5b8g0119g3wxd4n8mlf707y41vlf59irxjj0kynankfn")))
(define-public aspell-dict-it
- (aspell-dictionary "it" "Italian"
- #:version "2.2_20050523-0"
- #:sha256
- (base32
- "1gdf7bc1a0kmxsmphdqq8pl01h667mjsj6hihy6kqy14k5qdq69v")))
+ (let ((version "2.4-20070901-0")
+ (sha256
+ (base32 "0d6ypii3jblprpibazb6ypady536jz62rwxlss1x1raq07rhvvqn")))
+ (package
+ (inherit (aspell-dictionary "it" "Italian"
+ #:version version
+ #:sha256 sha256))
+
+ ;; The version hosted at <https://ftp.gnu.org/gnu/aspell/dict> is even
+ ;; more out of date.
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/linguistico/"
+ "Dizionario%20italiano%20per%20Aspell/" version "/"
+ "aspell6-it-" version ".tar.bz2"))
+ (sha256 sha256)))
+ (home-page
+ "http://linguistico.sourceforge.net/pages/dizionario_italiano.html"))))
(define-public aspell-dict-nl
(aspell-dictionary "nl" "Dutch"