aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/arcan.scm
diff options
context:
space:
mode:
authorAhmad Draidi <a.r.draidi@redscript.org>2023-08-10 22:16:36 +0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-05 19:50:46 -0400
commit076660f2ef1ca9fa35137e8520d77b7dcb41ee63 (patch)
treec243681f4165a9e4a630e5926916153accb30fbe /gnu/packages/arcan.scm
parent2b6b951f555ab07257256dcf53c841262f1e1b3e (diff)
downloadguix-076660f2ef1ca9fa35137e8520d77b7dcb41ee63.tar
guix-076660f2ef1ca9fa35137e8520d77b7dcb41ee63.tar.gz
gnu: arcan: Use new style arguments.
* gnu/packages/arcan.scm (arcan)[arguments]: Use new style arguments. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/arcan.scm')
-rw-r--r--gnu/packages/arcan.scm50
1 files changed, 24 insertions, 26 deletions
diff --git a/gnu/packages/arcan.scm b/gnu/packages/arcan.scm
index 9d18f7a52a..ee32f05b64 100644
--- a/gnu/packages/arcan.scm
+++ b/gnu/packages/arcan.scm
@@ -79,32 +79,30 @@
(delete-file-recursively "external/sqlite")))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-DBUILD_PRESET=everything"
- "-DDISTR_TAG='Guix'")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-paths
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "src/platform/posix/paths.c"
- (("/usr/local")
- (assoc-ref outputs "out")))))
- ;; Normally, it tries to fetch patched openal with git
- ;; but copying files manually in the right place seems to work too.
- (add-after 'unpack 'prepare-static-openal
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((arcan-openal (assoc-ref inputs "arcan-openal")))
- (copy-recursively arcan-openal "external/git/openal"))
- #t))
- (add-after 'prepare-static-openal 'generate-man
- (lambda _
- (with-directory-excursion "doc"
- (invoke "ruby" "docgen.rb" "mangen"))
- #t))
- (add-before 'configure 'chdir
- (lambda _
- (chdir "src")
- #t)))
- #:tests? #f))
+ (list #:configure-flags #~'("-DBUILD_PRESET=everything"
+ "-DDISTR_TAG='Guix'")
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "src/platform/posix/paths.c"
+ (("/usr/local")
+ (assoc-ref outputs "out")))))
+ ;; Normally, it tries to fetch patched openal with git
+ ;; but copying files manually in the right place seems to work too.
+ (add-after 'unpack 'prepare-static-openal
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((arcan-openal (assoc-ref inputs
+ "arcan-openal")))
+ (copy-recursively arcan-openal
+ "external/git/openal")) #t))
+ (add-after 'prepare-static-openal 'generate-man
+ (lambda _
+ (with-directory-excursion "doc"
+ (invoke "ruby" "docgen.rb" "mangen")) #t))
+ (add-before 'configure 'chdir
+ (lambda _
+ (chdir "src") #t)))
+ #:tests? #f))
(inputs
`(("bash-minimal" ,bash-minimal)
("espeak" ,espeak)