aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/agda.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-07-13 21:04:11 +0200
committer宋文武 <iyzsong@member.fsf.org>2023-07-22 11:29:31 +0800
commit3ec8acd3dfe9f512acb8bfa3cf572d5de03d1a3b (patch)
treee44318d6f1673f21ef34b381a901eda144d956cf /gnu/packages/agda.scm
parent03ae5bb866151de7c19561a7da6f477156e4b305 (diff)
downloadguix-3ec8acd3dfe9f512acb8bfa3cf572d5de03d1a3b.tar
guix-3ec8acd3dfe9f512acb8bfa3cf572d5de03d1a3b.tar.gz
gnu: agda-cubical: Update to 0.5.
* gnu/packages/agda.scm (agda-cubical): Update to 0.5. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/agda.scm')
-rw-r--r--gnu/packages/agda.scm51
1 files changed, 24 insertions, 27 deletions
diff --git a/gnu/packages/agda.scm b/gnu/packages/agda.scm
index 88626b823c..3748ab7059 100644
--- a/gnu/packages/agda.scm
+++ b/gnu/packages/agda.scm
@@ -262,34 +262,31 @@ try agda-prelude instead.")
;; Upstream's HEAD follows the latest Agda release, but they don't release
;; until a newer Agda release comes up, so their releases are always one
;; version late.
- (let* ((revision "1")
- (commit "814d54b08b360b8e80828065f54b80e3a98a0092"))
- (package
- (name "agda-cubical")
- (version (git-version "0.4" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/agda/cubical.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0d25gb1qzpx539k62qjsjq4xmzp34qk7n3hmd9y6v8slhrrxw312"))))
- (build-system agda-build-system)
- (arguments
- (list
- #:gnu-and-haskell? #t
- #:phases
- #~(modify-phases %standard-phases
- (replace 'build
- (lambda _
- (invoke "make"))))))
- (synopsis "Standard library for Cubical Agda")
- (description "A standard library for Cubical Agda, comparable to
+ (package
+ (name "agda-cubical")
+ (version "0.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/agda/cubical.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0yfg7gr55n08ly1qgzpcp16s15k1abycppbcdi9lzg1hjryqxcg3"))))
+ (build-system agda-build-system)
+ (arguments
+ (list
+ #:gnu-and-haskell? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'build
+ (lambda _
+ (invoke "make"))))))
+ (synopsis "Standard library for Cubical Agda")
+ (description "A standard library for Cubical Agda, comparable to
agda-stdlib but using cubical methods.")
- (home-page "https://github.com/agda/cubical")
- (license license:expat))))
+ (home-page "https://github.com/agda/cubical")
+ (license license:expat)))
(define-public agda-1lab
;; Upstream doesn't do releases (yet). Use a commit that builds with 2.6.3,