aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2024-03-17 08:46:41 +0800
committerHilton Chain <hako@ultrarare.space>2024-03-17 08:57:47 +0800
commitedfb05e16d409ab71f5cc5c91747b693f0054d59 (patch)
tree0c215e7f826f7083097cc02ec5151e2ac50d6837 /gnu/packages/admin.scm
parentfcf0fc0f33e6fc4ac96e585db5b048be620c3438 (diff)
downloadguix-edfb05e16d409ab71f5cc5c91747b693f0054d59.tar
guix-edfb05e16d409ab71f5cc5c91747b693f0054d59.tar.gz
gnu: wlgreet: Update to 0.4.1-1.7e79d60.
This is a follow-up to 0e9c2d2eba5e573e43382611474784c8bf5a4309 (sway 1.9 update), which breaks wlgreet 0.4.1. Reported in <https://issues.guix.gnu.org/69667>. * gnu/packages/admin.scm (wlgreet): Update to 0.4.1-1.7e79d60. Change-Id: I81613baac01d366d6fc507203fca2cc95977df46 Reported-by: chris <chris@bumblehead.com>
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm126
1 files changed, 64 insertions, 62 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c12d47da4b..2b94b1e17a 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -5516,71 +5516,73 @@ This allows greetd-pam-mount to auto-(un)mount @env{XDG_RUNTIME_DIR} without
interfering with any pam-mount configuration.")))
(define-public wlgreet
- (package
- (name "wlgreet")
- (version "0.4.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~kennylevinsen/wlgreet")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1k0jmgh0rjbnb49gkvs0a4d7z9xb6pad8v5w5f7my4s0rfpk7wd9"))))
- (build-system cargo-build-system)
- (arguments
- (list #:cargo-inputs
- `(("rust-chrono" ,rust-chrono-0.4)
- ("rust-getopts" ,rust-getopts-0.2)
- ("rust-greetd-ipc" ,rust-greetd-ipc-0.9)
- ("rust-lazy-static" ,rust-lazy-static-1)
- ("rust-memmap2" ,rust-memmap2-0.3)
- ("rust-nix" ,rust-nix-0.25)
- ("rust-os-pipe" ,rust-os-pipe-1)
- ("rust-rusttype" ,rust-rusttype-0.9)
- ("rust-serde" ,rust-serde-1)
- ("rust-smithay-client-toolkit"
- ,rust-smithay-client-toolkit-0.15)
- ("rust-toml" ,rust-toml-0.5)
- ("rust-wayland-client" ,rust-wayland-client-0.29)
- ("rust-wayland-protocols" ,rust-wayland-protocols-0.29))
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'remove-bundled-fonts
- (lambda _
- (delete-file-recursively "fonts")))
- (add-after 'remove-bundled-fonts 'fix-font-references
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/draw.rs"
- (("\\.\\./fonts/dejavu/DejaVuSansMono\\.ttf" _)
- (search-input-file
- inputs
- "share/fonts/truetype/DejaVuSansMono.ttf"))
- (("\\.\\./fonts/Roboto-Regular\\.ttf" _)
- (search-input-file
- inputs
- "share/fonts/truetype/Roboto-Regular.ttf")))))
- (add-after 'configure 'fix-library-references
- (lambda* (#:key inputs vendor-dir #:allow-other-keys)
- (substitute* (find-files vendor-dir "\\.rs$")
- (("lib(wayland-.*|xkbcommon)\\.so" so-file)
- (search-input-file
- inputs
- (string-append "lib/" so-file)))))))))
- (inputs
- (list font-dejavu
- font-google-roboto
- libxkbcommon
- wayland))
- (home-page "https://git.sr.ht/~kennylevinsen/wlgreet")
- (synopsis "Bare-bones Wayland-based greeter for @command{greetd}")
- (description
- "@command{wlgreet} provides a @command{greetd} greeter
+ (let ((commit "7e79d6004fc5e765a5c3ece6d377f8c5999d9dfa")
+ (revision "1"))
+ (package
+ (name "wlgreet")
+ (version (git-version "0.4.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~kennylevinsen/wlgreet")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "039a05v6c2i3al86k4fncqr3z47dnrz7y8wmhx6wvm08zx8s89ww"))))
+ (build-system cargo-build-system)
+ (arguments
+ (list #:cargo-inputs
+ `(("rust-chrono" ,rust-chrono-0.4)
+ ("rust-getopts" ,rust-getopts-0.2)
+ ("rust-greetd-ipc" ,rust-greetd-ipc-0.9)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-memmap2" ,rust-memmap2-0.3)
+ ("rust-nix" ,rust-nix-0.25)
+ ("rust-os-pipe" ,rust-os-pipe-1)
+ ("rust-rusttype" ,rust-rusttype-0.9)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-smithay-client-toolkit"
+ ,rust-smithay-client-toolkit-0.15)
+ ("rust-toml" ,rust-toml-0.5)
+ ("rust-wayland-client" ,rust-wayland-client-0.29)
+ ("rust-wayland-protocols" ,rust-wayland-protocols-0.29))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-bundled-fonts
+ (lambda _
+ (delete-file-recursively "fonts")))
+ (add-after 'remove-bundled-fonts 'fix-font-references
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/draw.rs"
+ (("\\.\\./fonts/dejavu/DejaVuSansMono\\.ttf" _)
+ (search-input-file
+ inputs
+ "share/fonts/truetype/DejaVuSansMono.ttf"))
+ (("\\.\\./fonts/Roboto-Regular\\.ttf" _)
+ (search-input-file
+ inputs
+ "share/fonts/truetype/Roboto-Regular.ttf")))))
+ (add-after 'configure 'fix-library-references
+ (lambda* (#:key inputs vendor-dir #:allow-other-keys)
+ (substitute* (find-files vendor-dir "\\.rs$")
+ (("lib(wayland-.*|xkbcommon)\\.so" so-file)
+ (search-input-file
+ inputs
+ (string-append "lib/" so-file)))))))))
+ (inputs
+ (list font-dejavu
+ font-google-roboto
+ libxkbcommon
+ wayland))
+ (home-page "https://git.sr.ht/~kennylevinsen/wlgreet")
+ (synopsis "Bare-bones Wayland-based greeter for @command{greetd}")
+ (description
+ "@command{wlgreet} provides a @command{greetd} greeter
that runs on a Wayland compositor such as @command{sway}. It
is implemented with pure Wayland APIs, so it does not depend
on a GUI toolkit.")
- (license license:gpl3)))
+ (license license:gpl3))))
(define-public libseat
(package