aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2024-09-08 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2024-09-08 02:00:00 +0200
commitbf6138e9ac1eb5965efb196c171d7e665100dbaa (patch)
treed8139fb22eb679840f41fa3324a83b232f9ad4e1 /gnu/packages/admin.scm
parent278cce9f610e10ebabe200bf7d0036617f7dae91 (diff)
downloadguix-bf6138e9ac1eb5965efb196c171d7e665100dbaa.tar
guix-bf6138e9ac1eb5965efb196c171d7e665100dbaa.tar.gz
gnu: stress-ng: Update to 0.18.04.
* gnu/packages/admin.scm (stress-ng): Update to 0.18.04. [arguments]: Skip more broken tests. Change-Id: Idd1d63e4b24304f5d97d50d7385bf64193fc43c1
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm23
1 files changed, 16 insertions, 7 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 832834707f..7a5fb3ca29 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2604,7 +2604,7 @@ system is under heavy load.")
(define-public stress-ng
(package
(name "stress-ng")
- (version "0.13.10")
+ (version "0.18.04")
(source
(origin
(method git-fetch)
@@ -2613,12 +2613,12 @@ system is under heavy load.")
(commit (string-append "V" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1z9vjn2131iv3pwrh04z6r5ygi1qgad5bi3jhghcvc3v1b4k5ran"))))
+ (base32 "100w4qkrzpg7jjl4dw0c376xi811qnjmlbffiy43i945f9vl3dc7"))))
(build-system gnu-build-system)
(arguments
;; XXX The test suite seems to cause instability on the VisionFive 2
;; build machines, maybe it's stressing them as intended but this is
- ;; unhelpful
+ ;; unhelpful.
(list #:tests? (not (target-riscv64?))
#:make-flags
#~(list (string-append "CC=" #$(cc-for-target))
@@ -2638,10 +2638,19 @@ system is under heavy load.")
(lambda* (#:key tests? #:allow-other-keys #:rest args)
(when tests?
(substitute* "debian/tests/fast-test-all"
- (("EXCLUDE=\"" exclude=)
- (string-append exclude=
- ;; Fails if host kernel denies ptracing.
- "ptrace ")))
+ (("^EXCLUDE=\"" exclude=)
+ (string-append
+ exclude=
+ (string-join
+ '("fpunch" ;fails for reasons not investigated
+ "prio-inv" ;requires elevated privileges
+ "ptrace") ;fails if host kernel denies ptracing
+ " ") " "))
+ ;; There's a commented list of ‘tests that can lock up
+ ;; some kernels or are CPU/arch specific’. Uncomment it.
+ (("#(EXCLUDE=)" _ uncomment) uncomment)
+ ;; Make it so that both lists are appended, with spaces.
+ (("EXCLUDE=\"") "EXCLUDE+=\" "))
(apply (assoc-ref %standard-phases 'check)
`(,@args #:test-target "fast-test-all"))))))))
(inputs