aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-11-14 19:52:29 +0100
committerLudovic Courtès <ludo@gnu.org>2023-11-15 11:36:20 +0100
commitaaee0e4af3809f8dbefb5d6efe251f0d73f8ed95 (patch)
tree3e087891bd66f0eb30a9e2c34ca40a04cdc2229e /gnu/packages/admin.scm
parentf8cad886153f4c0fa96d50e497eec5f00279f0d5 (diff)
downloadguix-aaee0e4af3809f8dbefb5d6efe251f0d73f8ed95.tar
guix-aaee0e4af3809f8dbefb5d6efe251f0d73f8ed95.tar.gz
gnu: launchmon: Fix compilation with GCC 11.
* gnu/packages/admin.scm (launchmon)[arguments]: New field. Change-Id: I30665896ef90e74b91055c85bcfe991af24f3a38
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index afbcf7fda6..6dbd6a116b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4432,6 +4432,9 @@ late.")
" *lmonpl = '\\0'"))
#t))))
(build-system gnu-build-system)
+ (arguments
+ ;; GCC 11 defaults to c++17 but this package needs something older.
+ (list #:configure-flags #~'("CXXFLAGS=-std=c++14 -O2 -g")))
(inputs
(list openmpi
munge
@@ -4439,7 +4442,7 @@ late.")
libelf
libgcrypt
libgpg-error))
- (synopsis "Infrastructue for large scale tool daemon launching")
+ (synopsis "Infrastructure for large-scale tool daemon launching")
(description
"LaunchMON is a software infrastructure that enables HPC run-time
tools to co-locate tool daemons with a parallel job. Its API allows a