aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-19 23:21:10 -0400
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:25 +0200
commit41cfdd7e501ea732ae8c0face983c004684fcb23 (patch)
treebd3a5f491fa812a47eaab276199f120cd174069c /gnu/packages/admin.scm
parent9a7b55d976c3caface7a1b41c9ff366600b9e348 (diff)
downloadguix-41cfdd7e501ea732ae8c0face983c004684fcb23.tar
guix-41cfdd7e501ea732ae8c0face983c004684fcb23.tar.gz
gnu: clusterssh: Add bash-minimal to inputs.
* gnu/packages/admin.scm (clusterssh) [inputs]: Add bash-minimal. [arguments]: Delete trailing #t. Change-Id: Icb6e0833e2dba3145c63294d003554c2de6bb169
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 0821e36cee..d19fa439be 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1803,8 +1803,7 @@ by bandwidth they use.")
(substitute* (list "lib/App/ClusterSSH/Config.pm"
"t/15config.t")
(("xterm")
- (which "xterm")))
- #t))
+ (which "xterm")))))
(add-before 'check 'delete-failing-tests
(lambda _
;; This checks whether all code is nicely formatted. The above
@@ -1812,8 +1811,7 @@ by bandwidth they use.")
(delete-file "t/perltidy.t")
;; Update the manifest so t/manifest.t happily passes.
(substitute* "MANIFEST"
- (("t/perltidy.t\n") ""))
- #t))
+ (("t/perltidy.t\n") ""))))
(add-after 'install 'augment-library-path
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -1838,8 +1836,7 @@ by bandwidth they use.")
"perl-try-tiny"
"perl-x11-protocol"
"perl-x11-protocol-other")))))))
- (find-files "." ".*")))
- #t))))))
+ (find-files "." ".*")))))))))
(native-inputs
(list perl-cpan-changes
perl-file-slurp
@@ -1854,7 +1851,8 @@ by bandwidth they use.")
perl-test-trap
perltidy))
(inputs
- (list perl-exception-class
+ (list bash-minimal ;for wrap-program
+ perl-exception-class
perl-sort-naturally
perl-tk
perl-try-tiny