aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-12-20 19:57:28 +0100
committerLudovic Courtès <ludo@gnu.org>2018-12-20 20:01:10 +0100
commitea8be005d409658dea4f4356e9279784ce0a5a39 (patch)
tree5e2e22332f37cbf171a75d524b60a87c7f8afd12 /gnu/packages.scm
parent86974d8a9247cbeb938b5202f23ccca8d9ed627d (diff)
downloadguix-ea8be005d409658dea4f4356e9279784ce0a5a39.tar
guix-ea8be005d409658dea4f4356e9279784ce0a5a39.tar.gz
gnu: Use i686-linux bootstrap binaries on x86_64-linux.
This saves 4.4 MB on the installed Guix. * gnu/packages/bootstrap/x86_64-linux: Remove directory. * gnu/local.mk (bootstrap_x86_64_linuxdir) (dist_bootstrap_x86_64_linux_DATA): Remove. * gnu/packages.scm (search-bootstrap-binary): When SYSTEM is "x86_64-linux", use "i686-linux" instead.
Diffstat (limited to 'gnu/packages.scm')
-rw-r--r--gnu/packages.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages.scm b/gnu/packages.scm
index 532297239d..333b18f9f0 100644
--- a/gnu/packages.scm
+++ b/gnu/packages.scm
@@ -102,14 +102,18 @@ FILE-NAME found in %PATCH-PATH."
(define (search-bootstrap-binary file-name system)
"Search the bootstrap binary FILE-NAME for SYSTEM. Raise an error if not
found."
- (or (search-path (%bootstrap-binaries-path)
- (string-append system "/" file-name))
- (raise (condition
- (&message
- (message
- (format #f (G_ "could not find bootstrap binary '~a' \
+ ;; On x86_64 always use the i686 binaries.
+ (let ((system (match system
+ ("x86_64-linux" "i686-linux")
+ (_ system))))
+ (or (search-path (%bootstrap-binaries-path)
+ (string-append system "/" file-name))
+ (raise (condition
+ (&message
+ (message
+ (format #f (G_ "could not find bootstrap binary '~a' \
for system '~a'")
- file-name system)))))))
+ file-name system))))))))
(define %distro-root-directory
;; Absolute file name of the module hierarchy. Since (gnu packages …) might