aboutsummaryrefslogtreecommitdiff
path: root/gnu/installer/services.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-12-05 14:41:48 +0900
committerLudovic Courtès <ludo@gnu.org>2019-01-17 14:04:23 +0100
commitb51bde71a9385f4e81fbea258bfb9e8ff48be119 (patch)
treeebcd1332428ed202df0a911366c93cd1d149849b /gnu/installer/services.scm
parentc088b2e47f6675199f1ef545df7d04d4532e64e3 (diff)
downloadguix-b51bde71a9385f4e81fbea258bfb9e8ff48be119.tar
guix-b51bde71a9385f4e81fbea258bfb9e8ff48be119.tar.gz
installer: Add services page.
Add a page to select services, for now only desktop environments choice is available. * gnu/installer.scm (steps): Add services step. * gnu/installer/newt.scm (newt-installer): Add services-page field. * gnu/installer/newt/services.scm: New file. * gnu/installer/record.scm (installer): Add services-page field. * gnu/installer/services.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add new files. * po/guix/POTFILES.in: Add new files.
Diffstat (limited to 'gnu/installer/services.scm')
-rw-r--r--gnu/installer/services.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnu/installer/services.scm b/gnu/installer/services.scm
new file mode 100644
index 0000000000..ed44b87682
--- /dev/null
+++ b/gnu/installer/services.scm
@@ -0,0 +1,59 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu installer services)
+ #:use-module (guix records)
+ #:export (<desktop-environment>
+ desktop-environment
+ make-desktop-environment
+ desktop-environment-name
+ desktop-environment-snippet
+
+ %desktop-environments
+ desktop-environments->configuration))
+
+(define-record-type* <desktop-environment>
+ desktop-environment make-desktop-environment
+ desktop-environment?
+ (name desktop-environment-name) ;string
+ (snippet desktop-environment-snippet)) ;symbol
+
+;; This is the list of desktop environments supported as services.
+(define %desktop-environments
+ (list
+ (desktop-environment
+ (name "GNOME")
+ (snippet '(gnome-desktop-service)))
+ (desktop-environment
+ (name "Xfce")
+ (snippet '(xfce-desktop-service)))
+ (desktop-environment
+ (name "MATE")
+ (snippet '(mate-desktop-service)))
+ (desktop-environment
+ (name "Enlightenment")
+ (snippet '(service enlightenment-desktop-service-type)))))
+
+(define (desktop-environments->configuration desktop-environments)
+ "Return the configuration field for DESKTOP-ENVIRONMENTS."
+ (let ((snippets
+ (map desktop-environment-snippet desktop-environments)))
+ `(,@(if (null? snippets)
+ '()
+ `((services (cons* ,@snippets
+ %desktop-services)))))))