aboutsummaryrefslogtreecommitdiff
path: root/gnu/installer.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-12-04 11:33:16 +0100
committerMathieu Othacehe <othacehe@gnu.org>2020-12-11 21:37:07 +0100
commit8361817bf693742757b096468198626f297bb09e (patch)
treefe2008436678b49cb81f66811345e0474da2bafe /gnu/installer.scm
parent6ca66f641485cc5a06ba7d34b9c36b738ea1d654 (diff)
downloadguix-8361817bf693742757b096468198626f297bb09e.tar
guix-8361817bf693742757b096468198626f297bb09e.tar.gz
install: Discover local substitute servers.
* gnu/installer/substitutes.scm: New file. * gnu/installer/newt/substitutes.scm: New file. * gnu/local.mk (INSTALLER_MODULES): Add them. * po/guix/POTFILES.in: Add gnu/installer/newt/substitutes.scm. * gnu/installer/proxy.scm (with-silent-shepherd): Move to ... * gnu/installer/utils.scm: ... here. * gnu/installer/record.scm (<installer>)[substitutes-page]: New field. * gnu/installer/newt.scm (substitutes-page): New procedure, (newt-installer): register it. * gnu/installer.scm (installer-steps): Add "substitutes-page" step. * gnu/system/install.scm (%installation-services): Add avahi-service-type and enable substitute server discover in guix-service-type. [<name-service-switch>]: Set it to %mdns-host-lookup-nss.
Diffstat (limited to 'gnu/installer.scm')
-rw-r--r--gnu/installer.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/installer.scm b/gnu/installer.scm
index f401b242f8..7863edbb67 100644
--- a/gnu/installer.scm
+++ b/gnu/installer.scm
@@ -266,6 +266,13 @@ selected keymap."
(compute (lambda _
((installer-network-page current-installer)))))
+ ;; Ask whether to enable substitute server discovery.
+ (installer-step
+ (id 'substitutes)
+ (description (G_ "Substitute server discovery"))
+ (compute (lambda _
+ ((installer-substitutes-page current-installer)))))
+
;; Prompt for users (name, group and home directory).
(installer-step
(id 'user)