aboutsummaryrefslogtreecommitdiff
path: root/gnu/installer.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-11-03 17:57:51 +0100
committerLudovic Courtès <ludo@gnu.org>2022-11-15 12:16:43 +0100
commit514fedbf3966b7fbab31a6c63b4210ec8b5b0c9a (patch)
treea52de4c819000a1f8507567f4f43eebdc0fab63a /gnu/installer.scm
parent6b39c3afccbc2fa91746f379f46f6acfa47c8f62 (diff)
downloadguix-514fedbf3966b7fbab31a6c63b4210ec8b5b0c9a.tar
guix-514fedbf3966b7fbab31a6c63b4210ec8b5b0c9a.tar.gz
installer: Report known-unsupported PCI devices.
* gnu/installer/hardware.scm: New file. * gnu/local.mk (INSTALLER_MODULES): Add it. * po/guix/POTFILES.in: Add it. * gnu/installer.scm (installer-steps): Pass #:pci-database to the 'welcome' step procedure. * gnu/installer/newt.scm (welcome-page): Add #:pci-database and pass it to 'run-welcome-page'. * gnu/installer/newt/welcome.scm (check-hardware-support): Add #:pci-database. Enumerate unsupported PCI devices and run an error page when unsupported devices are found. (run-welcome-page): Add #:pci-database and pass it to 'check-hardware-support' and to the recursive call. * gnu/installer/record.scm (<installer>)[welcome-page]: Adjust comment. * doc/guix.texi (Hardware Considerations): Mention it.
Diffstat (limited to 'gnu/installer.scm')
-rw-r--r--gnu/installer.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/installer.scm b/gnu/installer.scm
index df7625e05c..e1b040088b 100644
--- a/gnu/installer.scm
+++ b/gnu/installer.scm
@@ -46,6 +46,7 @@
#:use-module (gnu packages nano)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages package-management)
+ #:use-module (gnu packages pciutils)
#:use-module (gnu packages tls)
#:use-module (gnu packages xorg)
#:use-module (gnu system locale)
@@ -226,7 +227,9 @@ selected keymap."
(id 'welcome)
(compute (lambda _
((installer-welcome-page current-installer)
- #$(local-file "installer/aux-files/logo.txt")))))
+ #$(local-file "installer/aux-files/logo.txt")
+ #:pci-database
+ #$(file-append pciutils "/share/hwdata/pci.ids.gz")))))
;; Ask the user to select a timezone under glibc format.
(installer-step
@@ -358,6 +361,7 @@ selected keymap."
(with-extensions (list guile-gcrypt guile-newt
guile-parted guile-bytestructures
guile-json-3 guile-git guile-webutils
+ guile-zlib ;for (gnu build linux-modules)
(current-guix) gnutls)
(with-imported-modules `(,@(source-module-closure
`(,@modules