aboutsummaryrefslogtreecommitdiff
path: root/gnu/image.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-06-13 17:33:10 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-06-24 20:24:34 +0200
commitb904b59ce592c89dfb4675a8c06757afed6738a0 (patch)
tree8645a9b3f5d2609c552c7d25017843821812de78 /gnu/image.scm
parentaf0307a099ecfe6364da69415933d56dba33e055 (diff)
downloadguix-b904b59ce592c89dfb4675a8c06757afed6738a0.tar
guix-b904b59ce592c89dfb4675a8c06757afed6738a0.tar.gz
image: Move hurd image definition to a dedicated file.
This moves hurd-disk-image to a dedicated file. It also defines a default operating-system so that the image can be built standalone. * gnu/system/images/hurd.scm: New file, * gnu/local.mk (GNU_SYSTEM_MODULES): add it, * gnu/system/image.scm (root-offset, root-label): Export it, (hurd-disk-image): remove it as this is now defined in the new, Hurd dedicated file above, (find-image): adapt to avoid loop dependency.
Diffstat (limited to 'gnu/image.scm')
-rw-r--r--gnu/image.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/image.scm b/gnu/image.scm
index 19b466527b..dc66f2c533 100644
--- a/gnu/image.scm
+++ b/gnu/image.scm
@@ -67,6 +67,8 @@
(define-record-type* <image>
image make-image
image?
+ (name image-name ;symbol
+ (default #f))
(format image-format) ;symbol
(target image-target
(default #f))