aboutsummaryrefslogtreecommitdiff
path: root/gnu/ci.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2022-09-12 08:31:36 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-09-24 14:49:09 +0200
commitebe9d660a55629f2506db124b0e016885fc61e5c (patch)
tree9d6e9b7345a2b1ae214d4117428a0748501426af /gnu/ci.scm
parenta13f5ead0265cf0fe11e60150547c09dfc8c45b0 (diff)
downloadguix-ebe9d660a55629f2506db124b0e016885fc61e5c.tar
guix-ebe9d660a55629f2506db124b0e016885fc61e5c.tar.gz
gnu: Add compression module.
Move the compression record to a dedicated module so that it can be used outside (guix scripts pack) module. * guix/scripts/pack.scm (<compressor>, %compressors, lookup-compressor): Move it to ... * gnu/compression.scm: ... this new file. * gnu/ci.scm: Adapt it. * local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/ci.scm')
-rw-r--r--gnu/ci.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/ci.scm b/gnu/ci.scm
index 2c51ea7387..19a48bdbf1 100644
--- a/gnu/ci.scm
+++ b/gnu/ci.scm
@@ -39,9 +39,10 @@
#:select (gpl3+ license? license-name))
#:use-module ((guix utils) #:select (%current-system))
#:use-module ((guix scripts pack)
- #:select (lookup-compressor self-contained-tarball))
+ #:select (self-contained-tarball))
#:use-module (gnu bootloader)
#:use-module (gnu bootloader u-boot)
+ #:use-module (gnu compression)
#:use-module (gnu image)
#:use-module (gnu packages)
#:use-module (gnu packages gcc)