aboutsummaryrefslogtreecommitdiff
path: root/etc
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-20 22:19:24 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-22 20:35:15 -0400
commit4cf4dcb8b31274a8dfba6bae3a6826a1b521da3f (patch)
treea509036dc73ff679b6c6c5700bfbb60c26f92e09 /etc
parent85f934ccffbdc63f60633f1768fceb275a4e8252 (diff)
downloadguix-4cf4dcb8b31274a8dfba6bae3a6826a1b521da3f.tar
guix-4cf4dcb8b31274a8dfba6bae3a6826a1b521da3f.tar.gz
teams: Adjust shebang to use 'guix repl'.
This ensures the correct Guix dependencies are always available for the script. * etc/teams.scm.in: Rename to... * etc/teams.scm: ... this. Adjust shebang. * .gitignore: No longer ignore it. * configure.ac: Do not process it with AC_CONFIG_FILES. Reported-by: Clément Lassieur <clement@lassieur.org> Fixes: https://issues.guix.gnu.org/66605 Change-Id: I7a01750c6c5f0696b6c36b1e6caa9389d9e6822c
Diffstat (limited to 'etc')
-rwxr-xr-x[-rw-r--r--]etc/teams.scm (renamed from etc/teams.scm.in)8
1 files changed, 6 insertions, 2 deletions
diff --git a/etc/teams.scm.in b/etc/teams.scm
index 703d76fe8d..f3d4c73132 100644..100755
--- a/etc/teams.scm.in
+++ b/etc/teams.scm
@@ -1,5 +1,9 @@
-#!@GUILE@ \
---no-auto-compile -s
+#!/bin/sh
+# Extra care is taken here to ensure this script can run in most environments,
+# since it is invoked by 'git send-email'.
+pre_inst_env_maybe=
+command -v guix > /dev/null || pre_inst_env_maybe=./pre-inst-env
+exec $pre_inst_env_maybe guix repl -- "$0" "$@"
!#
;;; GNU Guix --- Functional package management for GNU