aboutsummaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-08-26 22:11:04 +0200
committerLudovic Courtès <ludo@gnu.org>2013-08-26 22:20:27 +0200
commita987d2c02525efd1bf37b4bb5b5df405a06bd15c (patch)
tree65a4e9a5ec464cb3eb4ba2a08ce0656e00a59caa /doc
parent3e9066fcfc1fb249eeeb2708d98ae258a38c5b2b (diff)
downloadguix-a987d2c02525efd1bf37b4bb5b5df405a06bd15c.tar
guix-a987d2c02525efd1bf37b4bb5b5df405a06bd15c.tar.gz
derivations: Move 3 positional parameters into keyword parameters.
* guix/derivations.scm (derivation): Turn `system', `env-vars', and `inputs' into keyword parameters. (build-expression->derivation): Adjust accordingly. * gnu/packages/bootstrap.scm (%bootstrap-guile): Likewise. * tests/derivations.scm, tests/store.scm: Likewise. * doc/guix.texi (Derivations): Likewise.
Diffstat (limited to 'doc')
-rw-r--r--doc/guix.texi6
1 files changed, 3 insertions, 3 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 57b6412939..c82d5f7480 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -1113,7 +1113,7 @@ derivations as Scheme objects, along with procedures to create and
otherwise manipulate derivations. The lowest-level primitive to create
a derivation is the @code{derivation} procedure:
-@deffn {Scheme Procedure} derivation @var{store} @var{name} @var{system} @var{builder} @var{args} @var{env-vars} @var{inputs} [#:outputs '("out")] [#:hash #f] [#:hash-algo #f] [#:hash-mode #f]
+@deffn {Scheme Procedure} derivation @var{store} @var{name} @var{builder} @var{args} [#:outputs '("out")] [#:hash #f] [#:hash-algo #f] [#:hash-mode #f] [#:inputs '()] [#:env-vars '()] [#:system (%current-system)]
Build a derivation with the given arguments. Return the resulting store
path and @code{<derivation>} object.
@@ -1137,9 +1137,9 @@ to a Bash executable in the store:
(let ((builder ; add the Bash script to the store
(add-text-to-store store "my-builder.sh"
"echo hello world > $out\n" '())))
- (derivation store "foo" (%current-system)
+ (derivation store "foo"
bash `("-e" ,builder)
- '(("HOME" . "/homeless")) '())))
+ #:env-vars '(("HOME" . "/homeless")))))
list)
@result{} ("/nix/store/@dots{}-foo.drv" #<<derivation> @dots{}>)
@end lisp