aboutsummaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-04-06 11:34:49 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-04-14 10:29:11 +0200
commit4099b12f9f4561d0494c7765b484b53d9073b394 (patch)
treed01dc46f85c881576af8e8635adb023096672d86 /doc
parentecf0e22dcfbb8fe15898ea001471d8e3f6dd36ee (diff)
downloadguix-4099b12f9f4561d0494c7765b484b53d9073b394.tar
guix-4099b12f9f4561d0494c7765b484b53d9073b394.tar.gz
maint: Avoid EPS generation to fail silently, ensure reproducibility.
Currently, Graphviz' dot does not insert a %%CreationDate. ImageMagick's convert on PNG->EPS does insert a %%CreationDate but it respects SOURCE_DATE_EPOCH. * doc/local.mk (.png.eps): Split single shell command into separate recipe lines, prefixed by $(AM_V_at). (.dot.png): Likewise. Check that generated EPS file has no %%CreationDate. Change-Id: I5a03485c19c72f0c46411815c51290e52a8e5399
Diffstat (limited to 'doc')
-rw-r--r--doc/local.mk9
1 files changed, 5 insertions, 4 deletions
diff --git a/doc/local.mk b/doc/local.mk
index 6a6864a7f0..19359760cc 100644
--- a/doc/local.mk
+++ b/doc/local.mk
@@ -152,12 +152,13 @@ DOT_OPTIONS = \
mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
.dot.eps:
- $(AM_V_DOT)$(DOT) -Teps $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"; \
- mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
+ $(AM_V_DOT)$(DOT) -Teps $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"
+ $(AM_v_at)! grep -q %%CreationDate "$(srcdir)/$@.tmp"
+ $(AM_V_at)mv "$(srcdir)/$@.tmp" "$@"
.png.eps:
- $(AM_V_GEN)convert "$<" "$@-tmp.eps"; \
- mv "$@-tmp.eps" "$@"
+ $(AM_V_GEN)convert "$<" "$@-tmp.eps"
+ $(AM_V_at)mv "$@-tmp.eps" "$@"
# We cannot add new dependencies to `%D%/guix.pdf' & co. (info "(automake)
# Extending"). Using the `-local' rules is imperfect, because they may be