aboutsummaryrefslogtreecommitdiff
path: root/doc/local.mk
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-29 14:33:41 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-29 14:52:21 -0400
commit0d9619354bf6c51a26bee7eb52073023dedafd49 (patch)
tree2c092ec759cc081eabf217b23d3c142fa0ee5d45 /doc/local.mk
parent4d7b25a0e2abd77625cdc888c60da8e6add02bbd (diff)
downloadguix-0d9619354bf6c51a26bee7eb52073023dedafd49.tar
guix-0d9619354bf6c51a26bee7eb52073023dedafd49.tar.gz
doc: Fix a potential problem in man page generation rule.
Since commit ca8acad3 ("build: Add dependency on guix script for help2man targets."), the $< special Make variable in the recipe was matching scripts/guix instead of the more specific 'guix/scripts/%.scm' source. * doc/local.mk ($(srcdir)/%D%/guix-%.1): Move the scripts/guix prerequisite to the end.
Diffstat (limited to 'doc/local.mk')
-rw-r--r--doc/local.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/doc/local.mk b/doc/local.mk
index 9d1e3ff7e4..97f0c3a92a 100644
--- a/doc/local.mk
+++ b/doc/local.mk
@@ -230,7 +230,7 @@ $(srcdir)/%D%/guix.1: scripts/guix.in $(sub_commands_mans)
# source script (the first prerequisite) has been changed. The $(GOBJECTS)
# prerequisite is solely meant to force these docs to be made only after all
# Guile modules have been compiled. We also need the guix script to exist.
-$(srcdir)/%D%/guix-%.1: scripts/guix guix/scripts/%.scm $(GOBJECTS)
+$(srcdir)/%D%/guix-%.1: guix/scripts/%.scm $(GOBJECTS) scripts/guix
-@case '$?' in \
*$<*) $(AM_V_P) && set -x || echo " HELP2MAN $@"; \
$(gen_man) --output="$@" "guix $*";; \