aboutsummaryrefslogtreecommitdiff
path: root/doc.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-08-29 21:20:51 +0200
committerLudovic Courtès <ludo@gnu.org>2013-08-29 21:58:52 +0200
commita9424c0887f688e812e498a2556df4b1d9218268 (patch)
tree395f024c1dd65db7a393c9dbb906e548b9f41b2f /doc.am
parent88bd1804a25056591237c4163faeb4e42449244d (diff)
downloadguix-a9424c0887f688e812e498a2556df4b1d9218268.tar
guix-a9424c0887f688e812e498a2556df4b1d9218268.tar.gz
build: Build docs from the top-level Makefile.
This undoes commit 575ed8d ("doc: Create own Makefile.am in subdirectory."), and fixes a bug whereby "make pdf" or "make ps" wouldn't do anything. * doc/Makefile.am: Remove. * doc.am: New file. Use `-local' rules to build the image. * Makefile.am: Include it. * configure.ac: Use `-Woverride' to avoid undesired overridding of Automake rules.
Diffstat (limited to 'doc.am')
-rw-r--r--doc.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/doc.am b/doc.am
new file mode 100644
index 0000000000..afd492c605
--- /dev/null
+++ b/doc.am
@@ -0,0 +1,48 @@
+# GNU Guix --- Functional package management for GNU
+# Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+# Copyright © 2013 Andreas Enge <andreas@enge.fr>
+#
+# This file is part of GNU Guix.
+#
+# GNU Guix is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or (at
+# your option) any later version.
+#
+# GNU Guix is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+info_TEXINFOS = doc/guix.texi
+EXTRA_DIST += \
+ doc/fdl-1.3.texi \
+ doc/images/bootstrap-graph.dot \
+ doc/images/bootstrap-graph.eps
+
+infoimagedir = $(infodir)/images
+dist_infoimage_DATA = doc/images/bootstrap-graph.png
+
+# Try hard to obtain an image size and aspect that's reasonable for inclusion
+# in an Info or PDF document.
+DOT_OPTIONS = \
+ -Tpng -Gratio=.9 -Gnodesep=.005 -Granksep=.00005 \
+ -Nfontsize=9 -Nheight=.1 -Nwidth=.1
+
+.dot.png:
+ dot -Tpng $(DOT_OPTIONS) < "$<" > "$@.tmp"
+ mv "$@.tmp" "$@"
+
+.dot.eps:
+ dot -Teps $(DOT_OPTIONS) < "$<" > "$@.tmp"
+ mv "$@.tmp" "$@"
+
+# We cannot add new dependencies to `doc/guix.pdf' & co. (info "(automake)
+# Extending"). Using the `-local' rules is imperfect, because they may be
+# triggered after the main rule. Oh, well.
+pdf-local: doc/images/bootstrap-graph.png
+info-local: doc/images/bootstrap-graph.png
+ps-local: doc/images/bootstrap-graph.eps